Bug 253596 - textproc/libxml2 - error with new config option "validate" if not selected , it will not compile
Summary: textproc/libxml2 - error with new config option "validate" if not selected , ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-desktop (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-17 20:08 UTC by antispam007
Modified: 2021-05-05 00:21 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (desktop)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description antispam007 2021-02-17 20:08:10 UTC
When turning off the new option validation , the textproc/libxml2 will not compile.

ld: error: ././libs/libxml2.so: undefined reference to xmlValidatePopElement
cc: error: linker failed .....
Comment 1 commit-hook freebsd_committer 2021-05-05 00:17:43 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=cd8e694917d3c39e6e52daca283b597a8e1c6ff2

commit cd8e694917d3c39e6e52daca283b597a8e1c6ff2
Author:     Adriaan de Groot <adridg@FreeBSD.org>
AuthorDate: 2021-05-05 00:11:31 +0000
Commit:     Adriaan de Groot <adridg@FreeBSD.org>
CommitDate: 2021-05-05 00:17:11 +0000

    textproc/libxml2: fix build with VALIDATION option off

    Grab two commits from upstream that fix the build when
    --no-valid is passed to configure; in the ports build
    that translates to the VALIDATION option turned off.
    These come straight from GNOME GitLab, although I've
    bunged them into one patch-* file.

    Not bumping PORTREVISION, since with this option off
    it would never have built, and with the option on
    the resulting package is unchanged.

    PR:             253596

 textproc/libxml2/Makefile                          |  7 ----
 ...-106757e8c1e26ad9b8c924c7f304074b79e082c5 (new) | 39 ++++++++++++++++++++++
 2 files changed, 39 insertions(+), 7 deletions(-)
Comment 2 Adriaan de Groot freebsd_committer 2021-05-05 00:21:25 UTC
Confirmed, closed via upstream commits. Thanks for reporting.