Bug 253611 - Boot loader screen graphics broken after update to 13.0 BETA2
Summary: Boot loader screen graphics broken after update to 13.0 BETA2
Status: Closed Works As Intended
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 13.0-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords: loader
Depends on:
Blocks:
 
Reported: 2021-02-18 07:14 UTC by Igor Osminin
Modified: 2021-02-18 10:32 UTC (History)
1 user (show)

See Also:


Attachments
Boot loader screen (477.33 KB, image/jpeg)
2021-02-18 08:51 UTC, Igor Osminin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Osminin 2021-02-18 07:14:04 UTC
I upgraded from version 12.2 to 13.0 BETA2. No errors or warnings were noticed during the update. After that, broken pseudo graphics are displayed on the boot screen instead of images from /boot/images. Photo in the attachment
Comment 1 Igor Osminin 2021-02-18 08:51:54 UTC
Created attachment 222550 [details]
Boot loader screen
Comment 2 Yuri Pankov freebsd_committer 2021-02-18 09:46:29 UTC
If this is UEFI boot, you will need to manually update loader.efi in ESP.
Comment 3 Toomas Soome freebsd_committer 2021-02-18 09:54:34 UTC
(In reply to Igor from comment #0)

I only confirm what Yuri already wrote; this does happen because you have loader.efi installed in Efi System Partition (ESP), and the upgrade process does not update it.

To fix, you need to use mount -t msdosfs, find from mounted tree the *.efi binary, and update it from /boot/loader.efi. It may be <mntpoint>/efi/boot/bootx64.efi or <mountpoint>/efi/freebsd/loader.efi

Other way is to check output from efibootmgr -v, and then update the file.
Comment 4 Igor Osminin 2021-02-18 10:32:41 UTC
Thank you, I'll try!