Bug 253703 - sysutils/iocell: unbreak arm64 + other arches, fix for FBSD > 12
Summary: sysutils/iocell: unbreak arm64 + other arches, fix for FBSD > 12
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dave Cottlehuber
URL: https://reviews.freebsd.org/D28004
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-19 21:41 UTC by Dave Cottlehuber
Modified: 2021-06-30 10:11 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (robak)


Attachments
patch lifted from phab D28004 (1.30 KB, text/plain)
2021-02-19 21:41 UTC, Dave Cottlehuber
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Cottlehuber freebsd_committer 2021-02-19 21:41:16 UTC
Created attachment 222651 [details]
patch lifted from phab D28004

this enables non-amd64 architectures, which were always broken,
and fixes > 12, which is broken since BSD grep required tighter
regexes.

See:
- https://github.com/bartekrutkowski/iocell/pull/37
- https://reviews.freebsd.org/D28004

If people actually use datasets under:

- $ZROOT/iocell/jail/$UUID/root or $ZROOT/iocell/jail/$UUID/data

then I need to refine the regex a little. It's not clear to me if
that's expected usage.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2021-02-21 20:14:48 UTC
I can confirm that this fixes the build on powerpc64/12.
Comment 2 Dave Cottlehuber freebsd_committer 2021-04-07 19:19:50 UTC
Bartek - iocell is broken on all arm*, ppc, and 13+ at present. I'd like to commit it next week unless you have objections.
Comment 3 commit-hook freebsd_committer 2021-05-30 13:37:59 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=68fa173526465a755a9b7fdc5ee9b8761c2a47b1

commit 68fa173526465a755a9b7fdc5ee9b8761c2a47b1
Author:     Dave Cottlehuber <dch@FreeBSD.org>
AuthorDate: 2021-05-30 13:35:18 +0000
Commit:     Dave Cottlehuber <dch@FreeBSD.org>
CommitDate: 2021-05-30 13:35:18 +0000

    sysutils/iocell: enable more architectures & handle new BSD grep

    While iocell is a shell script and can work cross-platform, its evident
    that nobody has actually tried to use it on anything other than amd64.

    Use tighter egrep(1) invocations, that match the new default BSD grep
    now in 13.0+ and up.

    Approved by:            maintainer timeout
    Tested by:              linimon
    PR:                     253703
    Differential Revision:  https://reviews.freebsd.org/D28004

 sysutils/iocell/Makefile | 6 +++++-
 sysutils/iocell/distinfo | 4 +++-
 2 files changed, 8 insertions(+), 2 deletions(-)