Bug 253726 - unzip sync with NetBSD upstream
Summary: unzip sync with NetBSD upstream
Status: Closed DUPLICATE of bug 244181
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Yoshihiro Takahashi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-20 18:45 UTC by Alex Kozlov
Modified: 2021-02-23 13:44 UTC (History)
1 user (show)

See Also:


Attachments
sync with NetBSD upstream (4.34 KB, text/plain)
2021-02-20 18:45 UTC, Alex Kozlov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Kozlov freebsd_committer 2021-02-20 18:45:36 UTC
Created attachment 222686 [details]
sync with NetBSD upstream

Sync unzip in the base with the upstream from NetBSD (rev1.27),
mostly content of PR 244181 except GNUC compat part, which
needed more work and testing:
- Add support for password protected zip archives
- Use success/failure macro in exit()
- Mention ZIPX format in unzip(1)
Comment 1 Alex Kozlov freebsd_committer 2021-02-20 18:49:33 UTC
nyan@, can you please check this out?
Comment 2 Yoshihiro Takahashi freebsd_committer 2021-02-23 13:44:47 UTC

*** This bug has been marked as a duplicate of bug 244181 ***