Bug 253740 - multimedia/gstreamer1 fails to build
Summary: multimedia/gstreamer1 fails to build
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-multimedia (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-21 09:27 UTC by Alexander Mishin
Modified: 2021-04-26 09:34 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (multimedia)


Attachments
patch-grammar.y (292 bytes, patch)
2021-02-21 09:27 UTC, Alexander Mishin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Mishin 2021-02-21 09:27:08 UTC
Created attachment 222697 [details]
patch-grammar.y

A port multimedia/gstreamer1 fails to build.

gmake[6]: Entering directory '/usr/ports/multimedia/gstreamer1/work/gstreamer-1.16.2/gst/parse'
/usr/local/bin/bison -d -v -ppriv_gst_parse_yy ./grammar.y -o grammar.tab.c && \
mv grammar.tab.c grammar.tab_tmp.c && \
echo '#ifdef HAVE_CONFIG_H' > grammar.tab_tmp2.c && \
echo '#include <config.h>' >> grammar.tab_tmp2.c && \
echo '#endif' >> grammar.tab_tmp2.c && \
cat grammar.tab_tmp.c >> grammar.tab_tmp2.c && \
rm grammar.tab_tmp.c && \
mv grammar.tab_tmp2.c grammar.tab.c
./grammar.y:799.1-12: warning: deprecated directive: ‘%pure-parser’, use ‘%define api.pure’ [

Needs to reset terminal after that.
All builds ok after I changed grammar.y as suggested at a last line.
Comment 1 Alexander Mishin 2021-02-28 10:52:10 UTC
I think that it is my problem only and I solved it already for myself. So I close the report. Thanks
Comment 2 Martin MATO 2021-03-02 00:52:47 UTC
Got the same problem
the patch provided fixed it.
Thanks.
Comment 3 Marius Schamschula 2021-04-16 13:54:34 UTC
I ran into this same issue after updating my system to 13.0-RELEASE.
Comment 4 Daniel Becker 2021-04-22 18:30:24 UTC
Also seeing this after updating to 13.0-RELEASE.
Comment 5 Daniel Becker 2021-04-22 18:31:24 UTC
Can this be reopened, or will a new PR have to be created?
Comment 6 mark 2021-04-26 09:34:43 UTC
This actually seems to be some sort of library incompatibility not taken care of by the bison port dependencies (the real problem is bison crashing giving the deprecation warning, not the fact that gstreamer1 triggers a warning).

The workaround I found was to install ncurses from ports and rebuild libtextstyle.

I hope that gives someone enough information to point them in the direction of a real fix.  (I'd appreciate if anyone less out of touch with the FreeBSD community than myself can bring this to the attention of the right people, maybe the bison or libtextstyle port maintainer?)

I encountered the issue on FreeBSD 14.0-CURRENT (amd64) whilst installing gnome3 from ports in a couple of VirtualBox VMs.