Bug 253811 - graphics/lua-gd: update and add support for Lua 5.2
Summary: graphics/lua-gd: update and add support for Lua 5.2
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-24 10:18 UTC by Henrik Gulbrandsen
Modified: 2021-02-25 14:43 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (sergey.dyatko)


Attachments
graphics_lua-gd.diff (4.25 KB, patch)
2021-02-24 10:18 UTC, Henrik Gulbrandsen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Gulbrandsen 2021-02-24 10:18:55 UTC
Created attachment 222785 [details]
graphics_lua-gd.diff

The current version of graphics/lua-gd is restricted to Lua 5.1. This patch adds support for Lua 5.2 and updates to the latest GitHub version. There has not been an official tagged release since 2.0.33r2 back in 2006, but fixes on the track for 2.0.33r3 have built up over the years, so I'm pretty sure we want them.

Checklist:
    patch.......... works
    portlint -AC... happy
    portclippy..... silent
    poudriere...... passed on 12.2-RELEASE-p4
Comment 1 Sergey V. Dyatko 2021-02-24 10:27:17 UTC
looks good to me

Thanks
Comment 2 Fernando Apesteguía freebsd_committer 2021-02-25 06:56:47 UTC
Q/A: patch did not apply cleanly. Would you mind checking it?

Patch contains CRLF terminators. If you pasted it in bugzilla try to upload it as an attachment.
Comment 3 Henrik Gulbrandsen 2021-02-25 08:19:44 UTC
(In reply to Fernando Apesteguía from comment #2)

The problem is that the upload function doesn't work for me, and I haven't quite figured out why. I just get a "Malformed multipart POST: data truncated" from attachment.cgi no matter what I try, with or without JavaScript enabled.

In the meantime, I have uploaded the patch to my web server instead:

    https://www.gulbra.net/freebsd/ports/graphics_lua-gd.diff
Comment 4 Fernando Apesteguía freebsd_committer 2021-02-25 14:43:25 UTC
(In reply to Henrik Gulbrandsen from comment #3)
Sorry for that. I've never had this problem before.