Bug 253829 - x11/plasma5-plasma-workspace: carshes while adding empty space on menu bar
Summary: x11/plasma5-plasma-workspace: carshes while adding empty space on menu bar
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-24 22:28 UTC by Dongjue Xie
Modified: 2021-04-22 22:50 UTC (History)
2 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dongjue Xie 2021-02-24 22:28:24 UTC
KDE plasma crashes when trying to add empty space to the panel. This happened to me on FreeBSD 13 Current, and also the latest current FreeBSD 14.
Comment 1 Tobias C. Berner freebsd_committer 2021-02-24 23:40:33 UTC
Moin moin 

The same issue was also reported in IRC some time ago, but I could not reproduce it on my machine. 

There is also this upstream report for example
https://bugs.kde.org/show_bug.cgi?id=422914

mfg Tobias
Comment 2 Dongjue Xie 2021-02-24 23:53:44 UTC
(In reply to Tobias C. Berner from comment #1)
It's like I try to make KDE have mac style layout, where you have a top Global menu + spacer + all other stuff clocks etc.

then it will crash once you add the spacer.

I had the FreeBSD-14.0-CURRENT-amd64-20210218-fa3bd463cee-256776 with the latest KDE avilable.

The bug report looks the same to me.

Thank you very much.
Comment 3 Graham Perrin 2021-02-24 23:57:35 UTC
Also, I don't know whether this is a duplicate: 

426269 – KDE crashed when adding/moving spacer in a panel
<https://bugs.kde.org/show_bug.cgi?id=426269>
Comment 4 Adriaan de Groot freebsd_committer 2021-04-22 22:50:08 UTC
In upstream 422914 you can see a fix was merged for this, just in time for 5.21.4 which landed an hour ago. I closed upstream 426269 because that one was FreeBSD-reported, and am closing this one as "fixed" -- I posted upstream that I could reproduce it, and can no longer do so.