Bug 253851 - www/nextcloud : Update to 21.0.0 cause infinite memory leak
Summary: www/nextcloud : Update to 21.0.0 cause infinite memory leak
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bernard Spil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-25 18:23 UTC by Thibault Payet
Modified: 2021-03-13 18:12 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (brnrd)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thibault Payet 2021-02-25 18:23:59 UTC
After updating to  21.0.0, the occ upgrade command failed to memory allocation. When disabling php memory limit nextcloud will eat up all the memory (tested with 16G of ram and it eat it all).
Comment 1 Bernard Spil freebsd_committer 2021-02-27 19:45:32 UTC
Are you still experiencing this?

I ran into this at some point, but it disappeared.

Tried both 7.4 and 8.0 and cannot replicate at the moment.
Comment 2 Thibault Payet 2021-02-27 20:29:44 UTC
I test a simple reinstall with nextcloud-php74 (going from an older nextcloud-php73 version 20.0.4 [I had to use a backup of the software]) and I get the same kind of error.

PHP Fatal error:  Allowed memory size of 2147483648 bytes exhausted (tried to allocate 528384 bytes) in /usr/local/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php on line 133
Comment 3 niqck 2021-03-02 20:55:11 UTC
Had the same issue. Do you have APCu enabled? If so you need to enable it also for CLI in your php-config.
In /usr/local/etc/php/ext-20-apcu.ini add following: apc.enable_cli=1

That fixed it for me but no user can login anymore after the upgrade.
Comment 4 cayen14422 2021-03-04 16:10:29 UTC
MARKED AS SPAM
Comment 5 Zilon 2021-03-13 17:06:27 UTC
(In reply to niqck from comment #3)
Thank you! That fixed the upgrade issues for me.
Comment 6 Thibault Payet 2021-03-13 18:11:59 UTC
(In reply to niqck from comment #3)
Thank you, after applying this settings I no longer have this issue