Bug 253889 - net/wireguard: doesnt work without IPv6 enabled
Summary: net/wireguard: doesnt work without IPv6 enabled
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Bernhard Froehlich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-27 09:29 UTC by iron.udjin
Modified: 2021-02-27 11:51 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (decke)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description iron.udjin 2021-02-27 09:29:17 UTC
I have a VM with FreeBSD 13-STABLE where is disabled IPv6 because I don't need it. When I'm trying to start wireguard I'm getting:

# service wireguard start
[#] wireguard-go wg0
ERROR: (wg0) 2021/02/27 11:22:48 Failed to create TUN device: address family not supported by protocol family
[#] rm -f /var/run/wireguard/wg0.sock
netstat: inet6: unknown address family

wg0.conf:

[Interface]
Address = 192.168.222.1/32
PrivateKey = <key>
ListenPort = 51820

[Peer]
PublicKey = <key>
AllowedIPs = 192.168.222.2/32

Installed from ports:
wireguard-go-0.0.20210212,1
wireguard-1.0.20210223

Wireguard need to have possibility to work without IPv6 enabled.
Comment 1 Bernhard Froehlich freebsd_committer 2021-02-27 11:51:16 UTC
Feel free to send patches for this but I won't spend any time on it. Hey it's 2021 and IPv6 is here to stay.

Quite soon you will be able to use the wireguard kernel implementation in FreeBSD 13.0 that might also work fine with IPv4 only.