Bug 253936 - dns/libidn 1.36 released 22 July 2020
Summary: dns/libidn 1.36 released 22 July 2020
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Li-Wen Hsu
URL:
Keywords:
: 259409 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-01 14:42 UTC by Dennis Clarke
Modified: 2022-06-07 13:24 UTC (History)
3 users (show)

See Also:
gaod: maintainer-feedback+


Attachments
libidn 1.37 (2.73 KB, patch)
2021-07-12 12:17 UTC, Leo Vandewoestijne
no flags Details | Diff
libidn 1.38 (2.08 KB, patch)
2021-08-09 11:18 UTC, Leo Vandewoestijne
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Clarke 2021-03-01 14:42:41 UTC
While doing testing with 13.0-BETA4 I see libidn2-2.3.0_1 exists
but libidn-1.35 is still around. Just a thought that is could be
revved up.


-- 
Dennis Clarke
RISC-V/SPARC/PPC/ARM/CISC
UNIX and Linux spoken
GreyBeard and suspenders optional
Comment 1 Dennis Clarke 2021-07-08 02:15:21 UTC
Did this die or just not worth revving up to 1.36 or maybe 1.37 ?
Comment 2 Leo Vandewoestijne 2021-07-08 12:00:25 UTC
I spot 45 ports which use libidn-1.35,
but I wonder how many truly require the old lib (instead of libidn2).
Comment 3 Leo Vandewoestijne 2021-07-12 12:17:25 UTC
Created attachment 226387 [details]
libidn 1.37

This patch is simpel version upgrade (plus I've adjusted the patches).
And I've changed the order in Makefile (on demand of portfmt & portclippy).

Tested all fine with portlint, poudriere, portfmt, portclippy.
Comment 4 Dennis Clarke 2021-07-12 22:13:40 UTC
(In reply to Leo Vandewoestijne from comment #3)

Looks perfect. Should work just fine and yes I see there are ports that
still want the previous rev library ( as opposed to libidn2 ) and to be
fair this is a trivial matter not even worth thinking about. I have
never had problems with libidn or libidn2 even on strange systems. Just
release it and let the other port maintainers do what they do.
Comment 5 Hung-Yi Chen 2021-07-13 03:48:24 UTC
I agree we can just bump libidn to 1.37. The patch looks good to me.
Comment 6 Leo Vandewoestijne 2021-08-09 11:18:52 UTC
Created attachment 227043 [details]
libidn 1.38

While at it, I also was able to manage the same up to 1.38

Tested successfully in poudriere.
Comment 7 Leo Vandewoestijne 2021-11-08 15:20:20 UTC
PR 259409 is a duplicate of this PR.
Comment 8 Mikael Urankar freebsd_committer 2021-11-08 17:26:05 UTC
*** Bug 259409 has been marked as a duplicate of this bug. ***
Comment 9 Hung-Yi Chen 2021-12-22 07:58:03 UTC
The 1.38 patch looks good to me.
Comment 10 commit-hook freebsd_committer 2022-06-07 13:24:01 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=52dee6eb58148882bf196643e6b00efb46ba257b

commit 52dee6eb58148882bf196643e6b00efb46ba257b
Author:     Leo Vandewoestijne <freebsd@dns.company>
AuthorDate: 2022-06-07 13:20:44 +0000
Commit:     Li-Wen Hsu <lwhsu@FreeBSD.org>
CommitDate: 2022-06-07 13:23:18 +0000

    dns/libidn: Update to 1.38

    PR:             253936
    Reported by:    Dennis Clarke <dclarke@blastwave.org>
    Approved by:    maintainer

 dns/libidn/Makefile                      | 8 ++------
 dns/libidn/distinfo                      | 6 +++---
 dns/libidn/files/patch-po_LINGUAS (gone) | 8 --------
 dns/libidn/pkg-descr                     | 2 +-
 dns/libidn/pkg-plist                     | 2 +-
 5 files changed, 7 insertions(+), 19 deletions(-)