Bug 253951 - net-mgmt/pnp: 0.6.26 uses deprecated php functions get_magic_quotes_runtime() and get_magic_quotes_gpc()
Summary: net-mgmt/pnp: 0.6.26 uses deprecated php functions get_magic_quotes_runtime()...
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Lars Engels
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-02 10:47 UTC by Oleksandr Kryvulia
Modified: 2021-05-13 08:19 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (lme)


Attachments
patch (767 bytes, application/x-php)
2021-03-02 10:47 UTC, Oleksandr Kryvulia
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleksandr Kryvulia 2021-03-02 10:47:41 UTC
Created attachment 222914 [details]
patch

Running net-mgmt/pnp with php7 cause an error:

Please check the documentation for information about the following error.

Function get_magic_quotes_runtime() is deprecated
file [line]:

/usr/local/lib/kohana/system/libraries/Input.php [57]:

It is possible an upstream bug. Proposed patch simply disables using of this deprecated functions.