Bug 254025 - www/falkon-qtonly where www/falkon is present
Summary: www/falkon-qtonly where www/falkon is present
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-05 08:47 UTC by Graham Perrin
Modified: 2021-04-06 18:10 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2021-03-05 08:47:04 UTC
I assumed that the pkg routine would gracefully remove www/falkon before attempting to install www/falkon-qtonly … not so. 

What's normally done to avoid situations such as this with flavours?

----

root@mowa219-gjp4-8570p:~ # pkg search falkon
falkon-3.1.0                   Web browser based on Webengine and Qt Framework
falkon-qtonly-3.1.0            Web browser based on Webengine and Qt Framework
root@mowa219-gjp4-8570p:~ # pkg install falkon-qtonly
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating poudriere repository catalogue...
poudriere repository is up to date.
All repositories are up to date.
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        falkon-qtonly: 3.1.0 [FreeBSD]

Number of packages to be installed: 1

The process will require 10 MiB more space.
2 MiB to be downloaded.

Proceed with this action? [y/N]: y
[1/1] Fetching falkon-qtonly-3.1.0.txz: 100%    2 MiB   2.2MB/s    00:01    
Checking integrity... done (1 conflicting)
  - falkon-qtonly-3.1.0 [FreeBSD] conflicts with falkon-3.1.0 [installed] on /usr/local/bin/falkon
Checking integrity... done (0 conflicting)
Conflicts with the existing packages have been found.
One more solver iteration is needed to resolve them.
The following 3 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        falkon-qtonly: 3.1.0 [FreeBSD]

Number of packages to be installed: 1

The process will require 10 MiB more space.

Proceed with this action? [y/N]: y
Fetching falkon-3.1.0.txz: 100%    2 MiB   2.2MB/s    00:01    
[1/3] Deinstalling falkon-3.1.0...
[1/3] Deleting files for falkon-3.1.0: 100%
[2/3] Installing falkon-qtonly-3.1.0...
[2/3] Extracting falkon-qtonly-3.1.0: 100%
[2/3] Installing falkon-3.1.0...
pkg: falkon-3.1.0 conflicts with falkon-qtonly-3.1.0 (installs files into the same place).  Problematic file: /usr/local/bin/falkon
root@mowa219-gjp4-8570p:~ # pkg info -x falkon
falkon-qtonly-3.1.0
root@mowa219-gjp4-8570p:~ # pkg remove falkon-qtonly
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
        falkon-qtonly: 3.1.0

Number of packages to be removed: 1

The operation will free 10 MiB.

Proceed with deinstalling packages? [y/N]: y
[1/1] Deinstalling falkon-qtonly-3.1.0...
[1/1] Deleting files for falkon-qtonly-3.1.0: 100%
root@mowa219-gjp4-8570p:~ # pkg install falkon
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating poudriere repository catalogue...
poudriere repository is up to date.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        falkon: 3.1.0 [FreeBSD]

Number of packages to be installed: 1

The process will require 10 MiB more space.

Proceed with this action? [y/N]: y
[1/1] Installing falkon-3.1.0...
[1/1] Extracting falkon-3.1.0: 100%
=====
Message from falkon-3.1.0:

--
If you get wrong colors when watching videos, this is probably because your
system does not support hardware acceleration (see bug 237277): you can
disable it by starting the browser from command line with the --disable-gpu
option.
root@mowa219-gjp4-8570p:~ # pkg remove falkon && pkg install falkon-qtonly
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
        falkon: 3.1.0

Number of packages to be removed: 1

The operation will free 10 MiB.

Proceed with deinstalling packages? [y/N]: y
[1/1] Deinstalling falkon-3.1.0...
[1/1] Deleting files for falkon-3.1.0: 100%
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating poudriere repository catalogue...
poudriere repository is up to date.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        falkon-qtonly: 3.1.0 [FreeBSD]

Number of packages to be installed: 1

The process will require 10 MiB more space.

Proceed with this action? [y/N]: y
[1/1] Installing falkon-qtonly-3.1.0...
[1/1] Extracting falkon-qtonly-3.1.0: 100%
=====
Message from falkon-qtonly-3.1.0:

--
If you get wrong colors when watching videos, this is probably because your
system does not support hardware acceleration (see bug 237277): you can
disable it by starting the browser from command line with the --disable-gpu
option.
root@mowa219-gjp4-8570p:~ # exit
logout
% date ; uptime
Fri  5 Mar 2021 08:34:46 GMT
 8:34a.m.  up 11 mins, 5 users, load averages: 0.83, 1.38, 0.79
% uname -v
FreeBSD 14.0-CURRENT #88 main-n245277-0d3b3beeb25: Fri Mar  5 06:52:45 GMT 2021     root@mowa219-gjp4-8570p:/usr/obj/usr/src/amd64.amd64/sys/GENERIC-NODEBUG 
% freebsd-version -kru
14.0-CURRENT
14.0-CURRENT
14.0-CURRENT
% falkon
QWebEngineUrlScheme::registerScheme: Too late to register scheme "falkon"
QWebEngineUrlScheme::registerScheme: Too late to register scheme "extension"
Please register the custom scheme 'falkon' via QWebEngineUrlScheme::registerScheme() before installing the custom scheme handler.
Please register the custom scheme 'extension' via QWebEngineUrlScheme::registerScheme() before installing the custom scheme handler.
Use of deprecated not thread-safe setter, use setUrlRequestInterceptor instead.
Falkon: 1 extensions loaded
[4050:323055616:0305/083503.625979:ERROR:nss_util.cc(283)] After loading Root Certs, loaded==false: NSS error code: -8018
%
Comment 1 Graham Perrin 2021-03-06 03:29:01 UTC
From Matrix chat: 

> tcberner and [ade]: I should have put the Konsole transcript in a 
> separate file, sorry. Yes, the issue (as I perceive it) is a 
> pkg routine stopping midway through an installation, with 
> no forewarning of a conflict.
> 
> It was, to the best of my knowledge, my first experience of 
> installing a non-default flavour of any package.
Comment 2 commit-hook freebsd_committer 2021-04-06 18:06:43 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=3a8d615d89ff126bc8a1e80e6d503ac0b63c6c83

commit 3a8d615d89ff126bc8a1e80e6d503ac0b63c6c83
Author:     Adriaan de Groot <adridg@FreeBSD.org>
AuthorDate: 2021-04-06 18:04:26 +0000
Commit:     Adriaan de Groot <adridg@FreeBSD.org>
CommitDate: 2021-04-06 18:06:35 +0000

    Update www/falkon metadata

    The pkg-descr talks about features that are not present
    and has some grammatical weirdness. Since there are now
    flavors, describe the differences between the flavors as
    well, and add CONFLICTS to prevent the flavors from
    being co-installed.

    PR:             254025 254738 254026

 www/falkon/Makefile  |  7 ++++++-
 www/falkon/pkg-descr | 27 ++++++++++++++++-----------
 2 files changed, 22 insertions(+), 12 deletions(-)