Bug 254075 - dns/opendnssec2: Package build failed
Summary: dns/opendnssec2: Package build failed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Li-Wen Hsu
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2021-03-06 22:56 UTC by Jaap Akkerhuis
Modified: 2021-03-10 13:36 UTC (History)
3 users (show)

See Also:


Attachments
patch to fix the problem (1.02 KB, patch)
2021-03-06 22:56 UTC, Jaap Akkerhuis
jaap: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaap Akkerhuis 2021-03-06 22:56:02 UTC
Created attachment 223035 [details]
patch to fix the problem

This patch file was missing updating to 2.8.1. It fixes the pkg build problems.
Comment 1 Automation User 2021-03-06 23:12:09 UTC
Build and package info is available at https://gitlab.com/swills/freebsd-ports/pipelines/266527516
Comment 2 Michael Grimm 2021-03-10 10:27:40 UTC
I can confirm that your patch fixes the compilation issue.
From my point of view the port is ready to commit ;-)
Comment 3 commit-hook freebsd_committer 2021-03-10 13:36:02 UTC
A commit references this bug:

Author: lwhsu
Date: Wed Mar 10 13:35:37 UTC 2021
New revision: 568001
URL: https://svnweb.freebsd.org/changeset/ports/568001

Log:
  dns/opendnssec2: Add missing patch to fix the build

  PR:		254075
  Submitted by:	Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer)

Changes:
  head/dns/opendnssec2/files/patch-configure
Comment 4 Li-Wen Hsu freebsd_committer 2021-03-10 13:36:33 UTC
Committed, thanks. The PORTREVISION is no need to be bumped because there was no package built.