Bug 254119 - net-p2p/qbittorrent-nox 4.3.3_2 freebsd-13.0-rc1 Out Of Memory
Summary: net-p2p/qbittorrent-nox 4.3.3_2 freebsd-13.0-rc1 Out Of Memory
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL: https://github.com/qbittorrent/qBitto...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-08 02:17 UTC by 84918960@qq.com
Modified: 2021-03-26 00:27 UTC (History)
2 users (show)

See Also:
linimon: maintainer-feedback? (yuri)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 84918960@qq.com 2021-03-08 02:17:05 UTC
freebsd 13.0-rc1 qbittorrent-nox 4.3.3_2
16G memory,yesterday update qbittorrent-nox from 4.3.3_1 to 4.3.3_2
service restart qbittorrent 
top: Active memory speed up to 10G, and ssh disconnect.
hard restart ,the problem is again.
Comment 1 daniel.engberg.lists 2021-03-08 07:46:26 UTC
Yuri,

Can you please revert r566803? 2.0-branch is still not supported by upstream.
Upstream still uses 1.2 for releases (ref: https://www.qbittorrent.org/download.php )
Comment 2 Yuri Victorovich freebsd_committer 2021-03-08 08:22:41 UTC
(In reply to daniel.engberg.lists from comment #1)

Daniel,

Are you sure that it's libtorrent-rasterbar that leaks memory, and not qBittorrent itself?
Comment 3 daniel.engberg.lists 2021-03-08 09:19:18 UTC
No, but libtorrent 2.x support is WIP in main upstream branch so I would guess that you most likely will run into issues with the current release given the commit history.
Comment 4 Yuri Victorovich freebsd_committer 2021-03-26 00:26:44 UTC
net-p2p/libtorrent-rasterbar downgraded to 1.2.12
Comment 5 commit-hook freebsd_committer 2021-03-26 00:27:00 UTC
A commit references this bug:

Author: yuri
Date: Fri Mar 26 00:26:45 UTC 2021
New revision: 569229
URL: https://svnweb.freebsd.org/changeset/ports/569229

Log:
  net-p2p/libtorrent-rasterbar: Downgrade 2.0.2 -> 1.2.12

  2.0.2 is not stable, causes huge memory footprint and looks like WIP.

  PR:		254119
  Reported by:	84918960@qq.com et al.

Changes:
  head/net-p2p/libtorrent-rasterbar/Makefile
  head/net-p2p/libtorrent-rasterbar/distinfo
  head/net-p2p/libtorrent-rasterbar/pkg-plist