Bug 254200 - graphics/drm No sound from HDMI port
Summary: graphics/drm No sound from HDMI port
Status: Closed DUPLICATE of bug 237340
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-10 18:42 UTC by Steven Friedrich
Modified: 2021-03-19 11:22 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Friedrich 2021-03-10 18:42:38 UTC
Perhaps this should be reported against the base, i915kms.ko?

I get audio out from the front or back of the system (using the Realtek device), but When I select output to HDMI, I get no sound.
No sound from HDMI (pcm2) using i915kms.ko
I got verbose output, but I don't know quite what it means:
hdaa0: Original pins configuration:
ahcich3: hdaa0: nid   0x    as seq device       conn  jack    loc        color   
misc
hdaa0: 18 40000000 0  0  Line-out      None  Unknown 0x00       Unknown 0
hdaa0: 20 01014010 1  0  Line-out      Jack  1/8     Rear       Green   0
hdaa0: 23 411111f0 15 0  Speaker       None  1/8     Rear       Black   1
hdaa0: 24 01a19040 4  0  Mic           Jack  1/8     Rear       Pink    0
hdaa0: 25 411111f0 15 0  Speaker       None  1/8     Rear       Black   1
hdaa0: 26 411111f0 15 0  Speaker       None  1/8     Rear       Black   1
hdaa0: 27 01813030 3  0  Line-in       Jack  1/8     Rear       Blue    0
hdaa0: 29 40434601 0  1  SPDIF-out     None  ATAPI   0x00       Green   6
hdaa0: 30 411111f0 15 0  Speaker       None  1/8     Rear       Black   1
hdaa0: 33 02211020 2  0  Headphones    Jack  1/8     Front      Black   0
hdaa0: Patching widget caps nid=29 0x00400000 -> 0x00700000
SATA offline status=00000004
hdaa0: ahcich3: AHCI reset: device not found
ahcich4: AHCI reset...
Patched pins configuration:
ahcich4: hdaa0: nid   0x    as seq device       conn  jack    loc        color   
misc
hdaa0: 18 40000000 0  0  Line-out      None  Unknown 0x00       Unknown 0 DISA
hdaa0: 20 01014010 1  0  Line-out      Jack  1/8     Rear       Green   0
hdaa0: 23 411111f0 15 0  Speaker       None  1/8     Rear       Black   1 DISA
hdaa0: 24 01a19040 4  0  Mic           Jack  1/8     Rear       Pink    0
hdaa0: 25 411111f0 15 0  Speaker       None  1/8     Rear       Black   1 DISA
hdaa0: 26 411111f0 15 0  Speaker       None  1/8     Rear       Black   1 DISA
hdaa0: 27 01813030 3  0  Line-in       Jack  1/8     Rear       Blue    0
hdaa0: 30 411111f0 15 0  Speaker       None  1/8     Rear       Black   1 DISA
hdaa0: 33 02211020 2  0  Headphones    Jack  1/8     Front      Black   0
hdaa0: 4 associations found:
hdaa0: Association 0 (1) out:
hdaa0:  Pin nid=20 seq=0
hdaa0: Association 1 (2) out:
hdaa0:  Pin nid=33 seq=0
hdaa0: Association 2 (3) in:
hdaa0:  Pin nid=27 seq=0
hdaa0: Association 3 (4) in:
hdaa0:  Pin nid=24 seq=0
hdaa0: Tracing association 0 (1)
hdaa0:  Pin 20 traced to DAC 2
hdaa0: Association 0 (1) trace succeeded
hdaa0: Tracing association 1 (2)
hdaa0:  Pin 33 traced to DAC 3
hdaa0: Association 1 (2) trace succeeded
hdaa0: Tracing association 2 (3)
hdaa0:  Pin 27 traced to ADC 8
hdaa0: Association 2 (3) trace succeeded
hdaa0: Tracing association 3 (4)
hdaa0:  Pin 24 traced to ADC 9
hdaa0: Association 3 (4) trace succeeded
hdaa0: Looking for additional DAC for association 0 (1)
hdaa0: Looking for additional DAC for association 1 (2)
hdaa0: Looking for additional ADC for association 2 (3)
hdaa0: Looking for additional ADC for association 3 (4)
hdaa0: Tracing input monitor
hdaa0:  Tracing nid 11 to out
hdaa0:  nid 11 is input monitor
hdaa0:  Tracing nid 35 to out
hdaa0: Tracing other input monitors
hdaa0:  Tracing nid 24 to out
hdaa0:  Tracing nid 27 to out
hdaa0: Tracing beeper
SATA offline status=00000004
ahcich4: AHCI reset: device not found
ahcich5: AHCI reset...
hdaa0: Pin sense: nid=20 sense=0x80000000 (connected)
ahcich5: SATA offline status=00000004
hdaa0: ahcich2: ahcich5: AHCI reset: device not found
Pin sense: nid=33 sense=0x80000000 (connected)
hdaa0: FG config/quirks: forcestereo ivref50 ivref80 ivref100 ivref

I cut out pcm0 and pcm1 because they work.  Only pcm2 (HDMI) doesn't produce 
sound

hdacc1: <Intel Kaby Lake HDA CODEC> at cad 2 on hdac0
hdaa1: <Intel Kaby Lake Audio Function Group> at nid 1 on hdacc1
hdaa1: Subsystem ID: 0x80860101
hdaa1: NumGPIO=0 NumGPO=0 NumGPI=0 GPIWake=0 GPIUnsol=0
hdaa1: Original pins configuration:
hdaa1: nid   0x    as seq device       conn  jack    loc        color   misc
hdaa1:  3 18560010 1  0  Digital-out   Jack  Digital 0x18       Unknown 0
hdaa1: Patched pins configuration:
hdaa1: nid   0x    as seq device       conn  jack    loc        color   misc
hdaa1:  3 18560010 1  0  Digital-out   Jack  Digital 0x18       Unknown 0
hdaa1: 1 associations found:
hdaa1: Association 0 (1) out:
hdaa1:  Pin nid=3 seq=0
hdaa1: Tracing association 0 (1)
hdaa1:  Pin 3 traced to DAC 2
hdaa1: Association 0 (1) trace succeeded
hdaa1: Looking for additional DAC for association 0 (1)
hdaa1: Tracing input monitor
hdaa1: Tracing other input monitors
hdaa1: Tracing beeper
hdaa1: FG config/quirks: forcestereo ivref50 ivref80 ivref100 ivref
pcm2: <Intel Kaby Lake (HDMI/DP 8ch)> at nid 3 on hdaa1
pcm2: Playback:
pcm2:      Stream cap: 0x00000005 AC3 PCM
pcm2:         PCM cap: 0x001a07f0 16 24 32 bits, 32 44 48 88 96 176 192 KHz
pcm2:             DAC: 2
pcm2: 
pcm2:     nid=3 [pin: Digital-out (Jack)]
pcm2:       + <- nid=2 [audio output] [src: pcm]
pcm2: 
pcm2: Master Volume (OSS: vol): 0/0dB
pcm2:    +- ctl  1 (nid   3 in ):    mute
pcm2: 
pcm2: PCM Volume (OSS: pcm): 0/0dB
pcm2:    +- ctl  1 (nid   3 in ):    mute
pcm2: 
pcm2: Mixer "vol":
pcm2: Mixer "pcm":
pcm2: Soft PCM mixer ENABLED
pcm2: Playback channel matrix is: unknown, assuming 7.1 (disconnected)


It LOOKS like it's muted:
pcm2: Master Volume (OSS: vol): 0/0dB
pcm2:    +- ctl  1 (nid   3 in ):    mute
and
pcm2: PCM Volume (OSS: pcm): 0/0dB
pcm2:    +- ctl  1 (nid   3 in ):    mute

The LAST message looks annoying:
pcm2: Playback channel matrix is: unknown, assuming 7.1 (disconnected)


Oh, and mixer isn't any help:
mixer -f /dev/mixer2
Mixer vol        is currently set to 100:100
Mixer pcm      is currently set to 100:100

I read snd_hda (4),but it's Geek to me.
-- 
FreeBSD FreeBSD 12.2-RELEASE-p3 FreeBSD 12.2-RELEASE-p3 r369327 Special  amd64
HP-Slimline 290-p0014 Desktop
Using integrated UHD Graphics 630
Built drm from /usr/ports/drm-kmod
Comment 1 Grégory Reinbold 2021-03-16 21:13:06 UTC
Hi

Same issue here, but with a CometLake-S GT2 [UHD Graphics 630].

hw-probe: https://bsd-hardware.info/?probe=6e0891ce80

Regards
Comment 2 Alexey Dokuchaev freebsd_committer 2021-03-19 11:22:45 UTC

*** This bug has been marked as a duplicate of bug 237340 ***