Bug 254275 - archivers/rpm4: Remove not needed compiler:openmp use flag
Summary: archivers/rpm4: Remove not needed compiler:openmp use flag
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rodrigo Osorio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-14 12:21 UTC by Tomasz Kowalczyk
Modified: 2021-03-14 12:47 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (rodrigo)


Attachments
patch (481 bytes, patch)
2021-03-14 12:21 UTC, Tomasz Kowalczyk
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Kowalczyk 2021-03-14 12:21:33 UTC
Created attachment 223257 [details]
patch

rpm4 is pulling whole gcc build just to not really use openmp.
It builds fine with base clang, and working fine too.
To avoid gcc dependency remove compiler:openmp from USES.

Tested on FreeBSD 13, used this rpm4 to build whole linux-c7 pack.
No errors encountered.
Comment 1 VVD 2021-03-14 12:47:04 UTC
(In reply to kowalczt.fbsd from comment #0)
> Tested on FreeBSD 13
Work on 12.2 amd64 too.

Check this: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=252379