Bug 254279 - editors/vscode-1.53.2_2 fail to build: conflict node12
Summary: editors/vscode-1.53.2_2 fail to build: conflict node12
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hiroki Tagato
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-14 13:58 UTC by Fredo
Modified: 2021-06-26 11:57 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fredo 2021-03-14 13:58:51 UTC
===>  Checking if node12 is already installed
===>   Registering installation for node12-12.21.0 as automatic
Installing node12-12.21.0...
pkg-static: node12-12.21.0 conflicts with node-15.11.0 (installs files into the same place).  Problematic file: /usr/local/bin/node
*** Error code 1

Stop.
make[6]: stopped in /usr/ports/www/node12
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/www/node12
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/www/yarn-node12
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/www/yarn-node12
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/electron11
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/electron11
*** Error code 1
Comment 1 Li-Wen Hsu freebsd_committer 2021-03-14 15:26:56 UTC
Over to maintainer.

BTW, this port has been updated to 1.54.2, can you update your ports tree and try again?
Comment 2 Fredo 2021-03-14 16:21:10 UTC
Updated my ports and I can see the new vscode version. However, the port fails to build

===> Setting user-specified options for vscode-1.54.2 and dependencies
===>   vscode-1.54.2 depends on executable: zip - found
===>   vscode-1.54.2 depends on executable: electron11 - not found
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Uses Python 2.7 which is EOLed upstream.

It is scheduled to be removed on or after 2020-12-31.

===>  License MIT accepted by the user
===>   electron11-11.3.0_1 depends on file: /usr/local/sbin/pkg - found
===>   electron11-11.3.0_1 depends on package: yarn-node12>0 - not found
===>  Staging for yarn-node12-1.22.10
===>   yarn-node12-1.22.10 depends on package: node12>=12.0.0 - not found
===>  Installing for node12-12.21.0
===>  Checking if node12 is already installed
===>   Registering installation for node12-12.21.0 as automatic
Installing node12-12.21.0...
pkg-static: node12-12.21.0 conflicts with node-15.11.0 (installs files into the same place).  Problematic file: /usr/local/bin/node
*** Error code 1

Stop.
make[6]: stopped in /usr/ports/www/node12
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/www/node12
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/www/yarn-node12
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/www/yarn-node12
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/electron11
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/electron11
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/vscode
Comment 3 Hiroki Tagato freebsd_committer 2021-03-15 11:15:52 UTC
This is expected. Please uninstall www/node first and build editors/vscode.

Currently multiple node versions cannot coexist.
Comment 4 Rene Ladan freebsd_committer 2021-06-26 11:57:21 UTC
Just FYI, I'm removing www/node12 now as it has no more consumers and depends on lang/python27. The older www/node10 is still in use by textproc/kibana[67].