Bug 254446 - graphics/drm-fbsd12.0-kmod: (radeon) drmn0: forbidden register 0x00028b90 at 1259
Summary: graphics/drm-fbsd12.0-kmod: (radeon) drmn0: forbidden register 0x00028b90 at ...
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-20 22:30 UTC by Joerg Wunsch
Modified: 2021-03-20 22:45 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
Coredump info (473.65 KB, text/plain)
2021-03-20 22:45 UTC, Joerg Wunsch
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Wunsch freebsd_committer 2021-03-20 22:30:02 UTC
OS: FreeBSD 12.2-STABLE
HW: ATI Radeon HD 2400 PRO (RV610 GPU)

After 12.2 upgrade, using the radeonkms module as shipped with the kernel, everything worked but I always got that

libGL error: failed to load driver: radeon

error for all applications using OpenGL, and in general, graphics appeared to be slow (e.g. when switching virtual screens, xterm took a noticable time to redraw a terminal window).

Research indicated to use drm-fbsd12.0-kmod instead of the modules shipped with kernel.

Initial attempts to use these resulted in the system quickly panicking after a few minutes of X11 operation. Rebuilt all modules (and GPU firmware) today, now it appears to be stable, and the dreadful "failed to load driver" message is gone. Overall graphics performance appears OK now. Most OpenGL applications to work well. However, cad/horizon-eda (which requires OpenGL 3.2 as minimum) triggers kernel errors, and yields garbage in its drawing areas.

forbidden register 0x00028b90 at 1215
Invalid command stream !

Using the deprecated system-supplied kms modules, horizon-eda worked without problems.
Comment 1 Joerg Wunsch freebsd_committer 2021-03-20 22:45:20 UTC
Created attachment 223459 [details]
Coredump info

I was too fast.

Using the 3D viewer from cad/kicad-devel, the system panicked again.

Coredump info attached.

I'm reverting to the legacy module by now, for stability.