Bug 254542 - lang/mecrisp-stellaris: update to 2.5.8
Summary: lang/mecrisp-stellaris: update to 2.5.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Some People
Assignee: Neel Chauhan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-25 11:57 UTC by Robert Clausecker
Modified: 2021-03-29 18:51 UTC (History)
1 user (show)

See Also:
fuz: maintainer-feedback+


Attachments
lang/mecrisp-stellaris 2.5.6 → 2.5.8 update diff (2.83 KB, patch)
2021-03-25 11:57 UTC, Robert Clausecker
no flags Details | Diff
lang/mecrisp-stellaris 2.5.6 → 2.5.8 update diff (fixed) (2.87 KB, patch)
2021-03-25 18:15 UTC, Robert Clausecker
fuz: maintainer-approval+
Details | Diff
Makefile rejects (2.01 KB, patch)
2021-03-25 18:39 UTC, Neel Chauhan
no flags Details | Diff
lang/mecrisp-stellaris 2.5.8 Makefile (1.74 KB, text/plain)
2021-03-29 17:22 UTC, Robert Clausecker
fuz: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Clausecker 2021-03-25 11:57:29 UTC
Created attachment 223564 [details]
lang/mecrisp-stellaris 2.5.6 → 2.5.8 update diff

This patch updates the lang/mecrisp-stellaris port to 2.5.8.  The update fixes the code so it can be assembled for armv6 FreeBSD.  Due to some new as features required, the 12.2 base binutils are unfortunately no longer capable of assembling this port.
Comment 1 Neel Chauhan freebsd_committer 2021-03-25 14:26:11 UTC
Are the 13/14 binutils capable of building this port?
Comment 2 Robert Clausecker 2021-03-25 15:01:15 UTC
binutils have been removed from FreeBSD 13.  The LLVM toolchain is not able to build this port due to some shortcomings in the LLVM-internal assembler that cannot be addressed by means of a simple patch.
Comment 3 Neel Chauhan freebsd_committer 2021-03-25 16:18:26 UTC
Thanks!

In that case it's a good idea to set "maintainer-feedback" to "+" if you want this port update to be committed.
Comment 4 Robert Clausecker 2021-03-25 16:26:27 UTC
Maintainer feedback provided.  I am the maintainer.
Comment 5 Neel Chauhan freebsd_committer 2021-03-25 17:33:33 UTC
This patch does not apply:

root@omen:/usr/ports.dev/lang # svnlite patch ~/pr254542
U         mecrisp-stellaris/distinfo
C         mecrisp-stellaris/Makefile
>         rejected hunk @@ -11,31 +11,35 @@
Summary of conflicts:
  Text conflicts: 1
root@omen:/usr/ports.dev/lang #
Comment 6 Robert Clausecker 2021-03-25 18:15:56 UTC
Created attachment 223578 [details]
lang/mecrisp-stellaris 2.5.6 → 2.5.8 update diff (fixed)

That's strange.  It worked just fine when I tested it here at work (on a Linux box).  I've regenerated the patch on a FreeBSD system just in case.  Perhaps there is some sort of problem.
Comment 7 Neel Chauhan freebsd_committer 2021-03-25 18:39:04 UTC
Created attachment 223579 [details]
Makefile rejects

It still fails:

root@omen:/usr/ports.dev/lang # svnlite patch ~/x
C         mecrisp-stellaris/Makefile
>         rejected hunk @@ -11,31 +11,35 @@
U         mecrisp-stellaris/distinfo
Summary of conflicts:
  Text conflicts: 1
root@omen:/usr/ports.dev/lang #

About making the patch from a Linux box, my job is 100% Windows/.NET so when I have to contribute to Ports and am on my work PC, I basically have to ssh into my home desktop. My personal desktop/laptop and server do run FreeBSD, however.
Comment 8 Neel Chauhan freebsd_committer 2021-03-25 18:39:29 UTC
If you don't mind, could you please share the whole Makefile instead of just the diff?
Comment 9 Robert Clausecker 2021-03-25 20:51:43 UTC
(In reply to Neel Chauhan from comment #8)

I'm sorry.  I do not understand what the problem is.  A shell archive with the updated port is attached to bug #253938.  I hope at least that works for you.
Comment 10 Robert Clausecker 2021-03-27 22:20:10 UTC
Any updates?  Is there anything else I can provide?

It would be great if this update could get in before quarterly is forked off, so FreeBSD 13 users can install Mecrisp Stellaris using the package management.
Comment 11 Robert Clausecker 2021-03-29 17:22:26 UTC
Created attachment 223685 [details]
lang/mecrisp-stellaris 2.5.8 Makefile

Here's the Makefile, just in case there is some sort of problem with extracting the shar from Bug #253938.
Comment 12 Neel Chauhan freebsd_committer 2021-03-29 18:50:10 UTC
Thanks! I am going to commit it shortly.
Comment 13 Neel Chauhan freebsd_committer 2021-03-29 18:50:22 UTC
Committed!
Comment 14 commit-hook freebsd_committer 2021-03-29 18:51:10 UTC
A commit references this bug:

Author: nc
Date: Mon Mar 29 18:50:27 UTC 2021
New revision: 569496
URL: https://svnweb.freebsd.org/changeset/ports/569496

Log:
  lang/mecrisp-stellaris: Update to 2.5.8

  Also, statisfy portclippy where possible

  PR:		254542
  Submitted by:	Robert Clausecker <fuz AT fuz DOT su> (maintainer)

Changes:
  head/lang/mecrisp-stellaris/Makefile
  head/lang/mecrisp-stellaris/distinfo