Bug 254617 - ipfw man page synopsis misses nat show form
Summary: ipfw man page synopsis misses nat show form
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Lutz Donnerhacke
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2021-03-28 00:04 UTC by Oliver Kiddle
Modified: 2021-06-04 11:02 UTC (History)
3 users (show)

See Also:


Attachments
corrections to ipfw.8 man page (1.35 KB, patch)
2021-03-28 00:04 UTC, Oliver Kiddle
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kiddle 2021-03-28 00:04:11 UTC
Created attachment 223653 [details]
corrections to ipfw.8 man page

Found initially by guessing but confirmed with the source code, it is possible to do, e.g. "ipfw nat 1 show config" to examine the nat configuration. This is missing from the man page. I've attached a patch that adds "ipfw nat number show {config | log}" to the IN-KERNEL NAT subsection of SYNOPSIS.

Furthermore, under RULE ACTIONS, the nat entry could list the "global" special value which is documented in the later NAT section that this references. Where it is documented, it could be clearer that these are used in rule actions and not amongst the config options that are documented immediately before. "specials value" doesn't really make sense because "specials" is a plural noun and only "special" is an adjective – "special values" is better. A little further on, "examples about" should be "examples of". The attached patch also deals with these.
Comment 1 Lutz Donnerhacke freebsd_committer 2021-05-10 16:36:43 UTC
Thank you for your kind contribution.

Next steps: https://reviews.freebsd.org/D30172
Comment 2 commit-hook freebsd_committer 2021-06-04 10:57:02 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/src/commit/?id=c8250c5ada85fec8936e8eb8695d7cb80a3ce8ab

commit c8250c5ada85fec8936e8eb8695d7cb80a3ce8ab
Author:     Lutz Donnerhacke <donner@FreeBSD.org>
AuthorDate: 2021-05-10 16:30:42 +0000
Commit:     Lutz Donnerhacke <donner@FreeBSD.org>
CommitDate: 2021-06-04 10:55:59 +0000

    ipfw.8: synopsis misses nat show form

    Document the existing behavior, which is currently only available by
    reading third party documentation or the source code itself.

    PR:             254617
    Submitted by:   Oliver Kiddle
    MFC after:      2 weeks
    Differential Revision: https://reviews.freebsd.org/D30189

 sbin/ipfw/ipfw.8 | 16 +++++++++++-----
 1 file changed, 11 insertions(+), 5 deletions(-)