Bug 254646 - devel/pycharm-ce: update to 2020.3.5
Summary: devel/pycharm-ce: update to 2020.3.5
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Boris Samorodov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-29 22:16 UTC by Jonathan Chen
Modified: 2021-05-07 22:06 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (bsam)


Attachments
2020.3.3 -> 2020.3.5 (2.24 KB, patch)
2021-03-29 22:16 UTC, Jonathan Chen
no flags Details | Diff
2020.3.3 -> 2020.3.5 (1.17 KB, patch)
2021-04-11 23:22 UTC, Jonathan Chen
no flags Details | Diff
2020.3.3 -> 2020.3.5 (1.16 KB, patch)
2021-04-11 23:24 UTC, Jonathan Chen
no flags Details | Diff
2020.3.5 update (4.19 KB, patch)
2021-04-28 07:32 UTC, Jonathan Chen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Chen 2021-03-29 22:16:34 UTC
Created attachment 223693 [details]
2020.3.3 -> 2020.3.5

Update from 2020.3.3 to 2020.3.5
Comment 1 Alexander Vereeken 2021-04-11 15:24:04 UTC
Hello Jonathan,

would you like to include JAVA_VERSION=11 to fix https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=251630 ?
Comment 2 Alexander Vereeken 2021-04-11 15:24:31 UTC
Unsupported Java Version
Java 11 or newer is required to run the IDE.
Please contact support at https://jb.gg/ide/critical-startup-errors

Your JRE: 1.8.0_282-b08 amd64 (OpenJDK BSD Porting Team)
/usr/local/openjdk8/jre
Comment 3 Jonathan Chen 2021-04-11 23:22:23 UTC
Created attachment 224035 [details]
2020.3.3 -> 2020.3.5

Re-rolled patch to include USE_JAVA restriction.
Comment 4 Jonathan Chen 2021-04-11 23:24:23 UTC
Created attachment 224036 [details]
2020.3.3 -> 2020.3.5

One more time, without the superflous $FreeBSD$ tag
Comment 5 Jonathan Chen 2021-04-28 07:32:06 UTC
Created attachment 224487 [details]
2020.3.5 update

Re-rolled to fix pkg-plist