Bug 254668 - x11/nvidia-driver, etc.: Update to latest 465.24.02 and 460.73.01
Summary: x11/nvidia-driver, etc.: Update to latest 465.24.02 and 460.73.01
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-31 03:30 UTC by Jung-uk Kim
Modified: 2021-04-16 15:55 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments
Update NVIDIA driver to 465.19.01 (4.21 KB, patch)
2021-03-31 03:30 UTC, Jung-uk Kim
no flags Details | Diff
Update NVIDIA driver to 465.19.01 (6.04 KB, patch)
2021-03-31 03:52 UTC, Jung-uk Kim
no flags Details | Diff
Update NVIDIA driver to 465.24.02 and 460.73.01 (8.22 KB, patch)
2021-04-15 05:55 UTC, Jung-uk Kim
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jung-uk Kim freebsd_committer 2021-03-31 03:30:36 UTC
Created attachment 223720 [details]
Update NVIDIA driver to 465.19.01

NVIDIA released FreeBSD driver 465.19.01.

https://www.nvidia.com/Download/driverResults.aspx/171982/en-us

This driver finally included Vulkan driver for FreeBSD.  Since it is a beta release, I added x11/nvidia-driver-460 and x11/linux-nvidia-libs-460.  If the maintainer thinks adding *-465 is preferable, I can do that, too. :-)
Comment 1 Jung-uk Kim freebsd_committer 2021-03-31 03:52:03 UTC
Created attachment 223721 [details]
Update NVIDIA driver to 465.19.01

Sorry, I uploaded an incomplete patch.  Try this.
Comment 2 Jung-uk Kim freebsd_committer 2021-03-31 04:01:16 UTC
Vulkan driver seems working fine.  At least, vulkaninfo and vkmark worked for me.  For example, the following is output from my good old GTX 1650.

% vulkaninfo --summary
==========
VULKANINFO
==========

Vulkan Instance Version: 1.2.174


Instance Extensions: count = 18
-------------------------------
VK_EXT_acquire_xlib_display            : extension revision 1
VK_EXT_debug_report                    : extension revision 9
VK_EXT_debug_utils                     : extension revision 2
VK_EXT_direct_mode_display             : extension revision 1
VK_EXT_display_surface_counter         : extension revision 1
VK_KHR_device_group_creation           : extension revision 1
VK_KHR_display                         : extension revision 23
VK_KHR_external_fence_capabilities     : extension revision 1
VK_KHR_external_memory_capabilities    : extension revision 1
VK_KHR_external_semaphore_capabilities : extension revision 1
VK_KHR_get_display_properties2         : extension revision 1
VK_KHR_get_physical_device_properties2 : extension revision 1
VK_KHR_get_surface_capabilities2       : extension revision 1
VK_KHR_surface                         : extension revision 25
VK_KHR_surface_protected_capabilities  : extension revision 1
VK_KHR_wayland_surface                 : extension revision 6
VK_KHR_xcb_surface                     : extension revision 6
VK_KHR_xlib_surface                    : extension revision 6

Instance Layers: count = 1
--------------------------
VK_LAYER_NV_optimus NVIDIA Optimus layer 1.2.168  version 1

Devices:
========
GPU0:
        apiVersion         = 4202664 (1.2.168)
        driverVersion      = 1950662720 (0x7444c040)
        vendorID           = 0x10de
        deviceID           = 0x1f82
        deviceType         = PHYSICAL_DEVICE_TYPE_DISCRETE_GPU
        deviceName         = NVIDIA GeForce GTX 1650
        driverID           = DRIVER_ID_NVIDIA_PROPRIETARY
        driverName         = NVIDIA
        driverInfo         = 465.19.01
        conformanceVersion = 1.2.5.2
% vkmark --p immediate
=======================================================
    vkmark 2017.08-24-g53abc4f
=======================================================
    Vendor ID:      0x10DE
    Device ID:      0x1F82
    Device Name:    NVIDIA GeForce GTX 1650
    Driver Version: 1950662720
    Device UUID:    fdb87de810be3219a442649cde19d21d
=======================================================
[vertex] device-local=true: FPS: 5424 FrameTime: 0.184 ms
[vertex] device-local=false: FPS: 3759 FrameTime: 0.266 ms
[texture] anisotropy=0: FPS: 5268 FrameTime: 0.190 ms
[texture] anisotropy=16: FPS: 5249 FrameTime: 0.191 ms
[shading] shading=gouraud: FPS: 5172 FrameTime: 0.193 ms
[shading] shading=blinn-phong-inf: FPS: 5188 FrameTime: 0.193 ms
[shading] shading=phong: FPS: 5106 FrameTime: 0.196 ms
[shading] shading=cel: FPS: 5127 FrameTime: 0.195 ms
[effect2d] kernel=edge: FPS: 5182 FrameTime: 0.193 ms
[effect2d] kernel=blur: FPS: 4149 FrameTime: 0.241 ms
[desktop] <default>: FPS: 4822 FrameTime: 0.207 ms
[cube] <default>: FPS: 6069 FrameTime: 0.165 ms
[clear] <default>: FPS: 6172 FrameTime: 0.162 ms
=======================================================
                                   vkmark Score: 5129
=======================================================

vkmark score looks bad but it is a low-profile card.
Comment 3 Ka Ho Ng freebsd_committer 2021-03-31 05:27:39 UTC
(In reply to Jung-uk Kim from comment #2)

==========
VULKANINFO
==========

Vulkan Instance Version: 1.2.173


Instance Extensions: count = 18
-------------------------------
VK_EXT_acquire_xlib_display            : extension revision 1
VK_EXT_debug_report                    : extension revision 8
VK_EXT_debug_utils                     : extension revision 2
VK_EXT_direct_mode_display             : extension revision 1
VK_EXT_display_surface_counter         : extension revision 1
VK_KHR_device_group_creation           : extension revision 1
VK_KHR_display                         : extension revision 23
VK_KHR_external_fence_capabilities     : extension revision 1
VK_KHR_external_memory_capabilities    : extension revision 1
VK_KHR_external_semaphore_capabilities : extension revision 1
VK_KHR_get_display_properties2         : extension revision 1
VK_KHR_get_physical_device_properties2 : extension revision 1
VK_KHR_get_surface_capabilities2       : extension revision 1
VK_KHR_surface                         : extension revision 25
VK_KHR_surface_protected_capabilities  : extension revision 1
VK_KHR_wayland_surface                 : extension revision 6
VK_KHR_xcb_surface                     : extension revision 6
VK_KHR_xlib_surface                    : extension revision 6

Instance Layers: count = 1
--------------------------
VK_LAYER_NV_optimus NVIDIA Optimus layer 1.2.168  version 1

Devices:
========
GPU0:
        apiVersion         = 4202664 (1.2.168)
        driverVersion      = 1950662720 (0x7444c040)
        vendorID           = 0x10de
        deviceID           = 0x1b81
        deviceType         = PHYSICAL_DEVICE_TYPE_DISCRETE_GPU
        deviceName         = NVIDIA GeForce GTX 1070
        driverID           = DRIVER_ID_NVIDIA_PROPRIETARY
        driverName         = NVIDIA
        driverInfo         = 465.19.01
        conformanceVersion = 1.2.5.2

I can confirm it's working on GTX 1070 also by testing out vkcube-xcb.
Comment 4 yamagi 2021-03-31 13:35:49 UTC
Ah, finally Vulkan support. Thank you for the quick patch. I can confirm that it's working. The Witcher 3 is running fine in wine + dxvk. A walked around a little bit, seems stable and no render glitches. Only that my old and trusty Geforce 7500TI is too slow for the game, it's stuttering with ~15 FPS. A screenshot is here: https://deponie.yamagi.org/temp/tw3fbsd.jpg
Comment 5 Jung-uk Kim freebsd_committer 2021-04-15 05:55:11 UTC
Created attachment 224125 [details]
Update NVIDIA driver to 465.24.02 and 460.73.01

New drivers were released.

https://www.nvidia.com/Download/driverResults.aspx/172837/en-us
https://www.nvidia.com/Download/driverResults.aspx/172378/en-us
Comment 6 commit-hook freebsd_committer 2021-04-16 07:00:11 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=eb57a9e66188f486c9b52ed72ee7c5a95513bda5

commit eb57a9e66188f486c9b52ed72ee7c5a95513bda5
Author:     Alexey Dokuchaev <danfe@FreeBSD.org>
AuthorDate: 2021-04-16 06:55:12 +0000
Commit:     Alexey Dokuchaev <danfe@FreeBSD.org>
CommitDate: 2021-04-16 06:57:31 +0000

    Update nVidia driver, Linux libraries, and tools to version 460.73.01,
    which had added support for the following GPUs:

      - RTX A4000 and RTX A5000
      - T400, T600, and T1000

    PR:     254668

 x11/linux-nvidia-libs/Makefile | 2 +-
 x11/linux-nvidia-libs/distinfo | 5 ++---
 x11/nvidia-driver/Makefile     | 2 +-
 x11/nvidia-driver/distinfo     | 5 ++---
 x11/nvidia-settings/Makefile   | 2 +-
 x11/nvidia-settings/distinfo   | 5 ++---
 x11/nvidia-xconfig/Makefile    | 2 +-
 x11/nvidia-xconfig/distinfo    | 5 ++---
 8 files changed, 12 insertions(+), 16 deletions(-)
Comment 7 commit-hook freebsd_committer 2021-04-16 08:51:31 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=22a47a0e04ad1484206e364dc9ce62a638ff594e

commit 22a47a0e04ad1484206e364dc9ce62a638ff594e
Author:     Alexey Dokuchaev <danfe@FreeBSD.org>
AuthorDate: 2021-04-16 08:46:36 +0000
Commit:     Alexey Dokuchaev <danfe@FreeBSD.org>
CommitDate: 2021-04-16 08:50:13 +0000

    Unbreak nVidia driver build against new feature branch 465.xx, which
    now includes Vulkan driver for FreeBSD.

    We do not offer short-lived/beta driver versions as a port or package,
    but we try to support building against arbitrary DISTVERSIONs.  Add a
    note about it and sort Linux libraries' port pkg-plist while I'm here.

    PR:     254668

 x11/linux-nvidia-libs/pkg-plist | 6 +++---
 x11/nvidia-driver/Makefile      | 6 ++++++
 x11/nvidia-driver/pkg-plist     | 2 ++
 3 files changed, 11 insertions(+), 3 deletions(-)
Comment 8 Alexey Dokuchaev freebsd_committer 2021-04-16 09:09:38 UTC
(In reply to Jung-uk Kim from comment #0)
> Since it is a beta release, I added x11/nvidia-driver-460 and
> x11/linux-nvidia-libs-460.  If the maintainer thinks adding *-465 is preferable,
> I can do that, too.
Sorry, but no.  We won't be serving short-lived/beta driver versions as a port or package, this is too large of a commitment to make.  Current matrix -- that is, combination of the main driver, three legacy drivers, and the same for Linux libraries, is already hard enough to test and maintain.  We do, however, aim to support building those ports against arbitrary DISTVERSIONs, because naturally, at some point beta version would turn stable and those hooks would stay.

That said, enthusiastic users who wish to play with 465.xx should be able to do that by typing ``make DISTVERSION=465.19.01 -DNO_CHECKSUM ...'' which should DTRT now.
Comment 9 Jung-uk Kim freebsd_committer 2021-04-16 15:55:20 UTC
(In reply to Alexey Dokuchaev from comment #8)
> Sorry, but no.  We won't be serving short-lived/beta driver versions as a port
> or package, this is too large of a commitment to make.  Current matrix -- that
> is, combination of the main driver, three legacy drivers, and the same for Linux 
> libraries, is already hard enough to test and maintain.

Understood.  BTW, 465.xx branch became "feature branch" and 460.xx is "production branch" now.

> That said, enthusiastic users who wish to play with 465.xx should be able to do
> that by typing ``make DISTVERSION=465.19.01 -DNO_CHECKSUM ...'' which should
> DTRT now.

Fair enough.  Thanks!