Bug 254704 - lang/erlang-runtime23: update to 23.3.1 and fix odbc option
Summary: lang/erlang-runtime23: update to 23.3.1 and fix odbc option
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jimmy Olgeni
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-01 23:34 UTC by Kim Shrier
Modified: 2021-04-09 13:38 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (erlang)


Attachments
patch to update erlang-runtime23 from 23.2.7 to 23.3.1 (2.61 KB, patch)
2021-04-01 23:34 UTC, Kim Shrier
no flags Details | Diff
patch to update erlang-runtime23 to 23.3.1, fix ODBC option, and updates wxWidgets to 3.0 (3.08 KB, patch)
2021-04-04 16:20 UTC, Kim Shrier
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kim Shrier 2021-04-01 23:34:24 UTC
Created attachment 223759 [details]
patch to update erlang-runtime23 from 23.2.7 to 23.3.1

This patch updates lang/erlang-runtime23 to the latest maintenance release for version 23.  In addition, it fixes selecting the ODBC option.

I noticed in testing that when selecting the NATIVE option, that there is a hipe error.  Since it looks like hipe is not being maintained, I wonder if both the NATIVE and HIPE options should be dropped.

If this update is acceptable, I would like to upgrade lang/erlang, lang/erlang-doc, lang/erlang-java, lang/erlang-man, and lang/erlang-wx as a next step in bringing the default Erlang version up to date.

Kim
Comment 1 Kim Shrier 2021-04-04 16:17:54 UTC
I did some additional testing and I have some changes to my original diff.

I also updated wxWidgets to 3.0.
Comment 2 Kim Shrier 2021-04-04 16:20:51 UTC
Created attachment 223804 [details]
patch to update erlang-runtime23 to 23.3.1, fix ODBC option, and updates wxWidgets to 3.0