Bug 254720 - misc/rubygem-mimemagic upgrade 0.3.10
Summary: misc/rubygem-mimemagic upgrade 0.3.10
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks: 252098
  Show dependency treegraph
 
Reported: 2021-04-02 12:55 UTC by Matthias Fechner
Modified: 2021-04-08 18:21 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments
Upgrade to 0.3.10 (1.25 KB, patch)
2021-04-02 12:55 UTC, Matthias Fechner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Fechner freebsd_committer 2021-04-02 12:55:10 UTC
Created attachment 223769 [details]
Upgrade to 0.3.10

This upgrade is required for a security related upgrade of www/gitlab-ce.

I will commit this after the git migration is finished together with the gitlab-ce security upgrade.
Comment 1 commit-hook freebsd_committer 2021-04-06 07:53:02 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=5c0415a6535d6412598d5eb570abb8c0abcf441c

commit 5c0415a6535d6412598d5eb570abb8c0abcf441c
Author:     Matthias Fechner <mfechner@FreeBSD.org>
AuthorDate: 2021-04-06 07:24:03 +0000
Commit:     Matthias Fechner <mfechner@FreeBSD.org>
CommitDate: 2021-04-06 07:51:03 +0000

    Update to 0.3.10.
    This update is required for a security related upgrade of gitlab-ce.

    PR:             254720

 misc/rubygem-mimemagic/Makefile | 8 ++++++--
 misc/rubygem-mimemagic/distinfo | 6 +++---
 2 files changed, 9 insertions(+), 5 deletions(-)
Comment 2 Po-Chuan Hsieh freebsd_committer 2021-04-06 14:22:55 UTC
May I ask why do you always commit without maintainer approval?
Updating gitlab is not a good reason to do so.
Please DO NOT COMMIT UNAPPROVED CHANGE again.
Thanks!
Comment 4 Po-Chuan Hsieh freebsd_committer 2021-04-08 18:21:57 UTC
(In reply to Matthias Fechner from comment #3)

The link says "GitLab Security Release: 13.10.1, 13.9.5, and 13.8.7".
You should just update to 13.9.5, not 13.10.1.