Bug 254759 - net/gitup manual page, section and availability
Summary: net/gitup manual page, section and availability
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Nuno Teixeira
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-04 10:03 UTC by Graham Perrin
Modified: 2021-04-05 11:43 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (eduardo)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2021-04-04 10:03:22 UTC
<https://www.freebsd.org/cgi/man.cgi?query=gitup&apropos=0&sektion=0&manpath=FreeBSD+12.2-RELEASE+and+Ports&arch=default&format=html>

* finds nothing. 

<https://forums.freebsd.org/threads/ports-transitioned-to-git.79598/page-2#post-504238> uses this phrase: 

> gitup(1)

Viewed after installing the package, the manual page has no section: 

----

GITUP                                LOCAL                               GITUP

NAME
     gitup – A minimalist, dependency-free program to clone/pull Git
     repositories.

SYNOPSIS
     gitup section [-ckrV] [-C configuration file] [-h commit checksum]
           [-t tag] [-u pack file] [-v verbosity] [-w commit checksum]

DESCRIPTION

…
Comment 1 Nuno Teixeira freebsd_committer 2021-04-05 01:09:09 UTC
Hi,

I can confirm this.
I think that https://www.freebsd.org/cgi/man.cgi only search for manpages in ${PREFIX}/man (deprecated) and not in ${PREFIX}/share/man

from /usr/ports/CHANGES:
20200115:
AUTHOR: bapt@FreeBSD.org

${PREFIX}/share/man is now a valid location for manpages ${PREFIX}/man being
considered as deprecated.
Comment 2 Nuno Teixeira freebsd_committer 2021-04-05 01:15:09 UTC
protclippy also installs manpage into ${PREFIX}/share/man and its available https://www.freebsd.org/cgi/man.cgi?query=portclippy&apropos=0&sektion=0&manpath=FreeBSD+12.2-RELEASE+and+Ports&arch=default&format=html

Needs investigation
Comment 3 Graham Perrin 2021-04-05 03:57:27 UTC
portclippy has a section (1). 

gitup does not.
Comment 4 Nuno Teixeira freebsd_committer 2021-04-05 10:35:12 UTC
Hi,

The reason why FreeBSD Manual Pages site doesn't show gitup manpage:

"releng/12.2" branch: Thu Sep 10 23:56:59 2020 UTC
Add gitup 0.87: Tue Dec 29 12:53:20 2020 UTC

Related to manpage section you can use https://github.com/johnmehr/gitup/issues and expose it there.

Thanks,

Nuno Teixeira
Comment 5 Graham Perrin 2021-04-05 11:43:09 UTC
Thanks. I don't understand the reason, but I trust you :-)

https://github.com/johnmehr/gitup/issues/57 for the section issue.