Bug 254790 - lang/c: Update to 0.14
Summary: lang/c: Update to 0.14
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL: https://github.com/ryanmjacobs/c/rele...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-05 14:01 UTC by Gian-Simon Purkert
Modified: 2021-04-11 16:12 UTC (History)
2 users (show)

See Also:
portmaster: maintainer-feedback+


Attachments
Update to 0.14 (862 bytes, patch)
2021-04-05 14:01 UTC, Gian-Simon Purkert
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gian-Simon Purkert 2021-04-05 14:01:45 UTC
Created attachment 223828 [details]
Update to 0.14
Comment 1 Fernando Apesteguía freebsd_committer 2021-04-08 07:08:21 UTC
^Triage: If there is a changelog or release notes URL available for this version, please add it to the URL field.


Thanks!
Comment 2 Chris Hutchinson 2021-04-08 17:44:30 UTC
Comment on attachment 223828 [details]
Update to 0.14

Approved.

MFC quarterly

Works/Builds as intended on 12/amd64

Thanks!

install  -m 555 lang/c/work/c-0.14/c lang/c/work/stage/usr/local/bin/c
====> Compressing man pages (compress-man)
====> Running Q/A tests (stage-qa)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
===> Checking for items in pkg-plist which are not in STAGEDIR
===> No pkg-plist issues found (check-plist)
Comment 3 Fernando Apesteguía freebsd_committer 2021-04-09 11:23:28 UTC
(In reply to Chris Hutchinson from comment #2)

Why the MFC? Does this fix specific bugs?
Comment 4 Chris Hutchinson 2021-04-09 16:36:29 UTC
(In reply to Fernando Apesteguía from comment #3)
Oops!
This is a version change. So MFC is obviously
unnecessary.

Sorry.

--Chris
Comment 5 commit-hook freebsd_committer 2021-04-11 15:46:52 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=c528a9327ae427eebba76a5de2297c138b016ee8

commit c528a9327ae427eebba76a5de2297c138b016ee8
Author:     Fernando Apesteguía <fernape@FreeBSD.org>
AuthorDate: 2021-04-08 07:06:17 +0000
Commit:     Fernando Apesteguía <fernape@FreeBSD.org>
CommitDate: 2021-04-11 15:42:30 +0000

    lang/c: Update to 0.14

    ChangeLog: https://github.com/ryanmjacobs/c/releases/tag/v0.14

    PR:     254790
    Reported by:    gspurki@gmail.com
    Approved by:    portmaster@bsdforge.com (maintainer)

 lang/c/Makefile | 2 +-
 lang/c/distinfo | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)
Comment 6 Fernando Apesteguía freebsd_committer 2021-04-11 16:12:52 UTC
Committed,

Thanks!