Bug 254811 - devel/libgit2: Fix build
Summary: devel/libgit2: Fix build
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Matthias Fechner
URL:
Keywords:
: 254814 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-04-06 11:34 UTC by Jordan Ostreff
Modified: 2021-04-08 10:36 UTC (History)
2 users (show)

See Also:


Attachments
Fix build (397 bytes, patch)
2021-04-06 14:40 UTC, Tomoaki AOKI
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jordan Ostreff 2021-04-06 11:34:26 UTC
Git ports tree pull to 4b13a4c45a26..6931339fc429 main. Doesn't build.

===>>> Currently installed version: libgit2-1.0.1
===>>> Port directory: /usr/ports/devel/libgit2

===>>> Starting check for build dependencies
===>>> Gathering dependency list for devel/libgit2 from ports
===>>> Dependency check complete for devel/libgit2

===>>> All >> libgit2-1.0.1 (1/1)

===>  Cleaning for libgit2-1.1.0
===>  License GPLv2 accepted by the user
===>   libgit2-1.1.0 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by libgit2-1.1.0 for building
===>  Extracting for libgit2-1.1.0
=> SHA256 Checksum OK for libgit2-1.1.0.tar.gz.
===>  Patching for libgit2-1.1.0
sed: /usr/ports/devel/libgit2/work/libgit2-1.1.0/cmake/Modules/SelectHTTPSBackend.cmake: No such file or directory
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/libgit2
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/libgit2

===>>> make build failed for devel/libgit2
===>>> Aborting update

===>>> Update for devel/libgit2 failed
===>>> Aborting update
Comment 1 Tomoaki AOKI 2021-04-06 14:40:07 UTC
Created attachment 223863 [details]
Fix build

This would fix build.
Applicable over /usr/ports.
Comment 2 Li-Wen Hsu freebsd_committer 2021-04-08 07:04:01 UTC
*** Bug 254814 has been marked as a duplicate of this bug. ***
Comment 3 Li-Wen Hsu freebsd_committer 2021-04-08 07:05:02 UTC
Over to maintainer.