Bug 254819 - ports system complains FreeBSD 12.1 is no longer supported
Summary: ports system complains FreeBSD 12.1 is no longer supported
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Mathieu Arnold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-06 14:54 UTC by Brett Wynkoop
Modified: 2021-04-06 15:07 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (mat)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brett Wynkoop 2021-04-06 14:54:10 UTC
root@prd1:/usr/ports/dns/bind916 # uname -a
FreeBSD prd1 12.1-RELEASE-p7 FreeBSD 12.1-RELEASE-p7 GENERIC  amd64
root@prd1:/usr/ports/dns/bind916 # make
/!\ ERROR: /!\

Ports Collection support for your FreeBSD version has ended, and no ports are
guaranteed to build on this system. Please upgrade to a supported release.

No support will be provided if you silence this message by defining
ALLOW_UNSUPPORTED_SYSTEM.

*** Error code 1

Stop.
make[1]: stopped in /usr/ports/dns/bind916
*** Error code 1

Stop.
make: stopped in /usr/ports/dns/bind916


I am at a loss as to how 12.1 can be unsupported when 13 is not yet even released.
Comment 1 Vidar Karlsen 2021-04-06 15:00:43 UTC
According to freebsd.org/releases[1] the currently supported releases are 11.4 and 12.2.

12.1 reached end-of-life in November, 2019.

[1] https://www.freebsd.org/releases/
Comment 2 Li-Wen Hsu freebsd_committer 2021-04-06 15:07:41 UTC
Yes please check https://www.freebsd.org/security/ for the support information and it's recommended to upgrade to the latest 12.x.