Bug 254832 - /dev/tty does not offer group "wheel" permission
Summary: /dev/tty does not offer group "wheel" permission
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: 12.2-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-06 19:30 UTC by RMM1
Modified: 2021-04-07 16:17 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RMM1 2021-04-06 19:30:11 UTC

    
Comment 1 RMM1 2021-04-06 19:37:28 UTC
/dev/ttyu0 is for mainboard UART
/dev/ttyU0 is for USB UART adapter

Only root has read-write permission for these devices. User account gets access denied.

I can do a root account loopback test (join pins 2 and 3 of the DB9 connector) so that whatever is typed is sent on TX and received on the RX pin using Minicom or Picocom.


If I do "chmod g+rw /dev/ttyu0" it works for the user account.
Comment 2 RMM1 2021-04-06 19:40:13 UTC
Chmod of the permission bits is a temporary test. It goes back to default after reboot or unplug of the USB adapter.
Comment 3 Andriy Gapon freebsd_committer 2021-04-07 07:53:09 UTC
You did not state what you consider to be a bug yet you opened a bug report.
If you are new to this kind of system configuration please seek help on forums (or even internet search).
Comment 4 RMM1 2021-04-07 15:29:57 UTC
I selected Problem Report Database which happens to use Bugzilla.  So I was reporting a problem. Ideally, some FreeBSD expert would evaluate the problem and decide if it is literal bug or a user issue. He/She would ask users for more details and filter a clean workflow for developers. 

My tests shows that the hardware works but the system does not enable it for users in the wheel group as the design intended.

I don't know how to enable it without compromising security.
Comment 5 Andriy Gapon freebsd_committer 2021-04-07 15:46:28 UTC
(In reply to RMM1 from comment #4)
> Ideally, some FreeBSD expert would evaluate the problem and decide if it is literal bug or a user issue.

And that's what happened.
There is no promise that group wheel has access to that type of hardware, so there is no bug.

If you have a question about how to configure FreeBSD to suite your needs, please ask it on forums.
Comment 6 Marek Zarychta 2021-04-07 16:17:36 UTC
It's rather not a bug, please take a look at devfs.conf(5) nam page and change /etc/devfs.conf to fulfill your needs.