Bug 254918 - devel/boost-libs (boost-libs-1.72.0_3) update error
Summary: devel/boost-libs (boost-libs-1.72.0_3) update error
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-09 14:03 UTC by bagas
Modified: 2021-04-09 17:16 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bagas 2021-04-09 14:03:39 UTC
Hello.
Update port boost-libs-1.72.0_3, an error appears at the end of the port build.
My system FreeBSD 11.4-RELEASE-p8 amd64.


pkg version -vl '<'
boost-libs-1.72.0_3 < needs updating (index has 1.72.0_4)



cp "bin.v2/libs/type_erasure/build/clang-linux-10.0.0/release/link-static/pch-off/threadapi-pthread/threading-multi/visibility-hidden/libboost_type_erasure-variant-static.cmake" "/usr/ports/devel/boost-libs/work/stage/usr/local/lib/cmake/boost_type_erasure-1.72.0/libboost_type_erasure-variant-static.cmake"

common.copy /usr/ports/devel/boost-libs/work/stage/usr/local/lib/cmake/boost_wave-1.72.0/libboost_wave-variant-static.cmake

cp "bin.v2/libs/wave/build/clang-linux-10.0.0/release/link-static/pch-off/threadapi-pthread/threading-multi/visibility-hidden/libboost_wave-variant-static.cmake" "/usr/ports/devel/boost-libs/work/stage/usr/local/lib/cmake/boost_wave-1.72.0/libboost_wave-variant-static.cmake"

common.copy /usr/ports/devel/boost-libs/work/stage/usr/local/lib/libboost_wave.a

cp "bin.v2/libs/wave/build/clang-linux-10.0.0/release/link-static/pch-off/threadapi-pthread/threading-multi/visibility-hidden/libboost_wave.a" "/usr/ports/devel/boost-libs/work/stage/usr/local/lib/libboost_wave.a"

...updated 15768 targets...
====> Compressing man pages (compress-man)
---> Backing up the old version
---> Uninstalling the old version
[Reading data from pkg(8) ... - 317 packages found - done]
---> Deinstalling 'boost-libs-1.72.0_3'
---> Preserving /usr/local/lib/libboost_atomic.so.1 as /usr/local/lib/compat/pkg/libboost_atomic.so.1
cp: symlink: libboost_atomic.so.1.72.0: File exists
Copy failed!
[Reading data from pkg(8) ... - 317 packages found - done]
** Listing the failed packages (-:ignored / *:skipped / !:failed)
! boost-libs-1.72.0_3 (copy failed)
** Listing the failed packages (-:ignored / *:skipped / !:failed)
! devel/boost-libs (boost-libs-1.72.0_3) (uninstall error)
Comment 1 Dima Panov freebsd_committer 2021-04-09 14:46:58 UTC
>---> Preserving /usr/local/lib/libboost_atomic.so.1 as >/usr/local/lib/compat/pkg/libboost_atomic.so.1
>cp: symlink: libboost_atomic.so.1.72.0: File exists
>Copy failed!

This is not a port itself bug but a local file storage mess (please take a look at your local /usr/local/lib/compat/pkg/ directory to check a staled file)
Comment 2 bagas 2021-04-09 15:39:11 UTC
What do you mean mess file store !?
I installed all programs from ports / usr / ports /
And updated portupgrade -arR
Comment 3 bagas 2021-04-09 15:48:54 UTC
not decided!
Comment 4 bagas 2021-04-09 15:51:41 UTC
no file.
# ls -al /usr/local/lib/compat/pkg/ | grep 'boost-libs'
Comment 5 bagas 2021-04-09 15:53:57 UTC
How can I fix the error?
Comment 6 bagas 2021-04-09 15:54:56 UTC
# ls -al /usr/local/lib/compat/pkg/ | grep 'libboost_atomic'
lrwxr-xr-x  1 root  wheel        25 12 нояб. 11:34 libboost_atomic.so.1 -> libboost_atomic.so.1.72.0
lrwxr-xr-x  1 root  wheel        25 23 авг.   2020 libboost_atomic.so.1.72 -> libboost_atomic.so.1.72.0
Comment 7 Dima Panov freebsd_committer 2021-04-09 16:11:57 UTC
(In reply to bagas from comment #6)
# rm /usr/local/lib/compat/pkg/libboost*
before run upgrade.

in your case it caused by portupgrade' handling his own compat backup dir. 

time to stop use abandonware and switch to pkg with synth/poudriere.
Comment 8 bagas 2021-04-09 16:43:31 UTC
made rm /usr/local/lib/compat/pkg/libboost*

reinstalled
cd /usr/ports/devel/boost-libs && make reinstall clean
...
...
...

    cp "bin.v2/libs/wave/build/clang-linux-10.0.0/release/link-static/pch-off/threadapi-pthread/threading-multi/visibility-hidden/libboost_wave.a"  "/usr/ports/devel/boost-libs/work/stage/usr/local/lib/libboost_wave.a"

...updated 15768 targets...
====> Compressing man pages (compress-man)
===>  Installing for boost-libs-1.72.0_4
===>  Checking if boost-libs is already installed
===>   Registering installation for boost-libs-1.72.0_4
[lovetab] Installing boost-libs-1.72.0_4...
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.

===>  Cleaning for boost-libs-1.72.0_4


I look at libraries, there are no libraries.
is that how it should be?
ls -al /usr/local/lib/compat/pkg/ | grep 'libboost'
Comment 9 bagas 2021-04-09 17:16:27 UTC
Solved