Bug 254993 - science/py-scipy: Fix incorrect Python <version-spec>
Summary: science/py-scipy: Fix incorrect Python <version-spec>
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-python (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-12 03:02 UTC by John Hein
Modified: 2021-05-05 02:46 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+
koobs: merge-quarterly?


Attachments
[patch] fix scipy supported py versions (406 bytes, patch)
2021-04-12 03:02 UTC, John Hein
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2021-04-12 03:02:03 UTC
Created attachment 224043 [details]
[patch] fix scipy supported py versions

scipy 1.6.0 does not support python3.6

RuntimeError: Python version >= 3.7 required.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-05-04 00:52:46 UTC
Thank you for the report John. Is quarterly also affected?
Comment 2 John Hein 2021-05-04 17:08:03 UTC
(In reply to Kubilay Kocak from comment #1)
It looks like 2021Q2 is at 1.6.0, so that is also affected.

2021Q1 is at 1.5.4

setup.py for 1.5.4 has:
    raise RuntimeError("Python version >= 3.6 required.")
Comment 3 John Hein 2021-05-05 01:47:56 UTC
QA:
  portlint (ok)
  poudriere (ok)
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2021-05-05 02:46:22 UTC
(In reply to John Hein from comment #2)

Only the latest quarterly branch is supported. Thank you for checking
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2021-05-05 02:46:53 UTC
Comment on attachment 224043 [details]
[patch] fix scipy supported py versions

Approved by: koobs (python, maintainer)
MFH: 2021Q2 (bugfix)