Bug 255000 - graphics/drm-fbsd12.0-kmod: fails to display anything on 12-STABLE
Summary: graphics/drm-fbsd12.0-kmod: fails to display anything on 12-STABLE
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-12 10:28 UTC by jau
Modified: 2021-04-13 00:07 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jau 2021-04-12 10:28:17 UTC
After I updated the drm-kmod stuff from source Xorg nolonger starts properly.
Previously it worked just fine. Now my flat screen only tells me ”out of range”
on a little blue box on otherwise completely black screen.
I assume this might be related to the fact that the package message says
”amdgpu and radeonkms are known to fail with EFI boot.”
The previous drn versions had no such problems. So, this is plain madness.
What is the point in updating the package in the ports tree, if it does not
operate at least as well as the preceeding versions?
For the last 10 years it has been quite common for tower case systems to boot using EFI + GPT. 
Publishing a kms version which suddenly no longer supports Radeon cards on systems
using EFI boot is bound to hurt quite a lot of people. Many such systems have been installed first time years ago assuming they can safely use EFI. 
Since the drm stuff has previously worked on system using EFI it probably should
not be impossible now either.
Comment 1 Evgeniy Khramtsov 2021-04-12 10:46:22 UTC
(In reply to jau from comment #0)

> Since the drm stuff has previously worked on system using EFI it probably should
> not be impossible now either.

Should be fixed with:
https://cgit.freebsd.org/src/commit/?id=8ebda6e44bb6ac9113e2a7fe65889811d894dd63
https://github.com/freebsd/drm-kmod/pull/61

> After I updated the drm-kmod stuff from source

See:
https://cgit.freebsd.org/doc/commit/?id=906851601568d15595e6c181bae741805d4fb3d6

I couldn't find this update yet in documentation, it will rebuild later, I guess.

Ensure that you are building drm-kmod with already updated and running world/kernel.
Comment 2 Niclas Zeising freebsd_committer 2021-04-12 14:01:59 UTC
FreeBSD 12.0 is no longer supported, the latest release of FreeBSD 12 is 12.2.
Comment 3 Niclas Zeising freebsd_committer 2021-04-12 17:56:23 UTC
(In reply to Niclas Zeising from comment #2)

I know the naming of the port, however, there is nowhere except in the headline you mention which FreeBSD version you are using, and there it says 12.0.

In any case, when running FreeBSD 12-stable, have you built the module locally using the same sources as you've built 12-stable from?  Are you on amd64 or i386?

What is in your dmesg?

In xorg.log?

What happens if you set hw.syscons.disable=1 in /boot/loader.conf (you won't have a console until the GPU driver loads).

Which previous version are you referring to?  drm-fbsd12.0-kmod hasn't changed much for quite some time, just build fixes and so on to keep up with changes in 12-stable.

FreeBSD 13.0 will be released today, or later this week, does it work if you use that instead?  If you have ZFS, you can create a separate boot environment or a snapshot to easily roll back to your previous release if needed.
Comment 4 Tatsuki Makino 2021-04-13 00:07:58 UTC
I write the following in /etc/rc.conf to load the module at a delayed time.

kld_list="/boot/modules/radeonkms.ko"

I have put the following file in /usr/local/etc/X11/xorg.conf.d to limit the DRI to DRI2.

Section "Device"
  Identifier "radeon"
  Driver "radeon"
  Option "DRI" "2"
EndSection


However, it is 12.2-STABLE stable/12-n232926-110ebf08868 amd64, Radeon HD6450 and EFI+boot0 boot :)
No problem with this combination of mine.