Bug 255087 - sysutils/desktop-installer
Summary: sysutils/desktop-installer
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Jason W. Bacon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-15 09:51 UTC by Ivan Zubov
Modified: 2021-04-16 15:30 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (jwb)


Attachments
Screen shot from VirtualBox (25.49 KB, image/png)
2021-04-15 18:24 UTC, Jason W. Bacon
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Zubov 2021-04-15 09:51:50 UTC
After choosing latest or quarterly packages (any choice) script got freeze and does nothing until CTRL+C.
Tested OS:
FreeBSD 12.2
FreeBSD 13 (from RC3 to RELEASE)
Tested platforms:
Microsoft Hyper-V
VirtualBOX 6.1.18
Desktop-installer runs from root user.
Comment 1 Ivan Zubov 2021-04-15 09:57:39 UTC
After half hour and couple ENTERs, script is continues his work
Comment 2 Jason W. Bacon freebsd_committer 2021-04-15 13:08:46 UTC
Thanks for the report.

You should not have to wait half an hour for feedback.  I have never seen symptoms like this, but will try to reproduce this on my end.
Comment 3 Jason W. Bacon freebsd_committer 2021-04-15 13:27:13 UTC
Not seeing this issue under VirtualBox here.  After responding y or n on updating to latest, it immediately begins cloning the ports tree, which takes about 1 minute.

I wonder if you actually have a video issue, so desktop-installer is running but the output is not displaying on your virtualized console.
Comment 4 Ivan Zubov 2021-04-15 16:16:28 UTC
You can download a video of that lag here:

https://dropmefiles.com/MDHct

As you can see, after choosing latest or quarterly the script freezed. After some time, and couple ENTERs - script continues its work.
Comment 5 Jason W. Bacon freebsd_committer 2021-04-15 18:24:19 UTC
Created attachment 224140 [details]
Screen shot from VirtualBox
Comment 6 Jason W. Bacon freebsd_committer 2021-04-15 18:27:24 UTC
Odd.  You should see git cloning the ports tree immediately after selecting a branch.

Does the ports tree exist after the delay?

What version of desktop-installer and auto-admin are installed? (run pkg info)

Might there be a corrupted /usr/ports directory from a previous failed run?  Try removing /usr/ports and running desktop-installer again.
Comment 7 Ivan Zubov 2021-04-15 19:01:16 UTC
Seems like i understood... The problem was in ports tree. I didn't install it by default. I'll try to reproduce that situation with ports tree installed, and let you know.
Comment 8 Ivan Zubov 2021-04-15 19:09:37 UTC
Now (with ports) it doesn't freeze, but still need two ENTERs on this step.
Comment 9 Ivan Zubov 2021-04-15 19:12:55 UTC
FreeBSD 13-RELEASE-0
desktop-installer 0.7.1
auto-admin 0.7.2
Comment 10 Jason W. Bacon freebsd_committer 2021-04-15 21:13:21 UTC
(In reply to Ivan Zubov from comment #7)

No, actually you should *not* install the ports tree under bsdinstall.  It shouldn't matter, but it would be a waste of time because the release ports tree will be replaced with a more current one by desktop-installer anyway.

You should remove /usr/ports entirely and then run desktop-installer to see if it still exhibits the problem.  I don't know how it will cope with a corrupted ports tree, though it should be fine with either a complete one or no /usr/ports directory.
Comment 11 Jason W. Bacon freebsd_committer 2021-04-15 21:13:44 UTC
(In reply to Ivan Zubov from comment #9)

OK, those are current, so they should work.
Comment 12 Jason W. Bacon freebsd_committer 2021-04-15 21:15:21 UTC
(In reply to Ivan Zubov from comment #8)

Can you share any non-default responses you gave to the FreeBSD installer?

Settings of your VirtualBox guest?
Comment 13 Ivan Zubov 2021-04-16 10:05:57 UTC
VirtualBox setting almost default exept two virtual CPU, 3072RAM, and HD audio. I/O APIC enabled by default.
FreeBSD settings:
Default locale
DHCP
ZFS (2G swap, single disk)
Software components:
lib32
ports (tested with and without ports)
without any debug and dumps
ntpdate
powerd
moused
no any hardering
pkg (quarterly and latest tested)
Comment 14 Jason W. Bacon freebsd_committer 2021-04-16 14:38:01 UTC
ZFS was triggering the problem here.  Because it creates a /usr/ports directory, it activates code that ensures your ports and packages are on the same branch.  I wasn't hitting this with UFS2.

As a workaround, open /usr/local/sbin/desktop-installer, search for auto-check-ports-branch, and remove the

> /dev/null

after it.  I had fixed this issue a while back, but somehow neglected to commit it.  Any update will be committed shortly.
Comment 15 Ivan Zubov 2021-04-16 14:50:38 UTC
Glad to hear that problem is found!
Comment 16 commit-hook freebsd_committer 2021-04-16 15:07:20 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=0e084ddc8634c8f8436c155ccb2f748a7549db80

commit 0e084ddc8634c8f8436c155ccb2f748a7549db80
Author:     Jason W. Bacon <jwb@FreeBSD.org>
AuthorDate: 2021-04-16 15:03:42 +0000
Commit:     Jason W. Bacon <jwb@FreeBSD.org>
CommitDate: 2021-04-16 15:06:39 +0000

    sysutils/desktop-installer: Fix accidentally silenced user prompt

    PR:             255087
    Reported by:    Ivan Zubov
    MFH:            2021Q2 (runtime fix)

 sysutils/desktop-installer/Makefile | 5 +++--
 sysutils/desktop-installer/distinfo | 6 +++---
 2 files changed, 6 insertions(+), 5 deletions(-)
Comment 17 commit-hook freebsd_committer 2021-04-16 15:12:22 UTC
A commit in branch 2021Q2 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=def8434018343c4dd65e18b0515a099b2ac6ea6c

commit def8434018343c4dd65e18b0515a099b2ac6ea6c
Author:     Jason W. Bacon <jwb@FreeBSD.org>
AuthorDate: 2021-04-16 15:03:42 +0000
Commit:     Jason W. Bacon <jwb@FreeBSD.org>
CommitDate: 2021-04-16 15:10:50 +0000

    sysutils/desktop-installer: Fix accidentally silenced user prompt

    PR:             255087
    Reported by:    Ivan Zubov
    MFH:            2021Q2 (runtime fix)

    (cherry picked from commit 0e084ddc8634c8f8436c155ccb2f748a7549db80)

 sysutils/desktop-installer/Makefile | 5 +++--
 sysutils/desktop-installer/distinfo | 6 +++---
 2 files changed, 6 insertions(+), 5 deletions(-)
Comment 18 Jason W. Bacon freebsd_committer 2021-04-16 15:16:21 UTC
Fixed in head and quarterly.  Binary packages should be updated within a few days.

Thanks for the report!
Comment 19 Ivan Zubov 2021-04-16 15:30:08 UTC
(In reply to Jason W. Bacon from comment #18)
Thank you!