Bug 255197 - textproc/py-docutils: Update to 0.17.1
Summary: textproc/py-docutils: Update to 0.17.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Thierry Thomas
URL: https://sourceforge.net/projects/docu...
Keywords:
: 255200 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-04-18 20:11 UTC by Thierry Thomas
Modified: 2021-04-22 16:18 UTC (History)
3 users (show)

See Also:
dbaio: maintainer-feedback+


Attachments
textproc/py-docutils: upgrade to 0.17.1. (1.17 KB, patch)
2021-04-18 20:11 UTC, Thierry Thomas
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Thomas freebsd_committer 2021-04-18 20:11:28 UTC
Created attachment 224230 [details]
textproc/py-docutils: upgrade to 0.17.1.

Changelog at <https://sourceforge.net/projects/docutils/files/docutils/0.17.1/README.txt>.
Comment 1 daniel.engberg.lists 2021-04-18 21:51:54 UTC
*** Bug 255200 has been marked as a duplicate of this bug. ***
Comment 2 Danilo G. Baio freebsd_committer 2021-04-19 01:01:20 UTC
make test:
  Ran 1444 tests in 5.648s
  OK (skipped=5)
  Elapsed time: 6.061 seconds


It's good to run a build test on all consumers, 
I've started one but it will take a while, if you already did that, please let us know.
Comment 3 Thierry Thomas freebsd_committer 2021-04-19 10:14:30 UTC
(In reply to Danilo G. Baio from comment #2)
I updated it on my workstation, hoping that it would solve the bug described at
https://sourceforge.net/p/docutils/bugs/385/

This is not explicitly written in the changelog, but the patch submitted in
https://sourceforge.net/p/docutils/code/8465/ is included.

Anyway, it was not sufficient to fix the breakage caused in math/sage by docutils 0.17, and I had to commit a work-around to avoid it.

Excepted Sage, I tested some consumers without noticing anything: this is a minor update.
Comment 4 Danilo G. Baio freebsd_committer 2021-04-20 11:05:28 UTC
(In reply to Thierry Thomas from comment #3)

Thanks for the info and for the patch.

Of all consumers just sage-math failed.
Comment 5 Danilo G. Baio freebsd_committer 2021-04-21 14:14:30 UTC
(In reply to Danilo G. Baio from comment #4)

Just to clarify, you can proceed with
Approved by: dbaio (python)

If you want me to commit, let me know.

Thanks!
Comment 6 Thierry Thomas freebsd_committer 2021-04-22 16:18:22 UTC
Committed, thanks!