Bug 255254 - graphics/darktable fails to start after pkg upgrade from latest
Summary: graphics/darktable fails to start after pkg upgrade from latest
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Jean-Sébastien Pédron
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-20 09:50 UTC by Ludger Bolmerg
Modified: 2021-04-29 21:59 UTC (History)
4 users (show)

See Also:
dumbbell: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludger Bolmerg 2021-04-20 09:50:13 UTC
after pkg upgrade from latest darktable issues the following error message:

ld-elf.so.1: /usr/local/bin/../lib/darktable/libdarktable.so: Undefined symbol "_ZTIN7Imf_3_09AttributeE"

I am on FreeBSD 13.0-RELEASE

#uname -a
FreeBSD dell 13.0-RELEASE FreeBSD 13.0-RELEASE #0 releng/13.0-n244733-ea31abc261f: Fri Apr  9 04:24:09 UTC 2021     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/amd64.amd64/sys/GENERIC  amd64

darktable is darktable-3.4.1
Comment 1 Ludger Bolmerg 2021-04-20 10:35:53 UTC
I suspect the error may have been caused by the split of graphics/ilmbase into math/Imath and graphics/openexr
Comment 2 Felix Palmen 2021-04-24 13:42:53 UTC
FWIW, confirming this issue with packages built locally with poudriere.
Comment 3 a.parseg 2021-04-29 16:25:20 UTC
I am also having this issue.

uname -a
FreeBSD thorium 13.0-RELEASE FreeBSD 13.0-RELEASE #0 releng/13.0-n244733-ea31abc261f: Fri Apr  9 04:24:09 UTC 2021     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/amd64.amd64/sys/GENERIC  amd64

darktable-3.4.1 first upgraded, then reinstalled from packages (tried pkg install -f, then pkg remove and install, made no difference). Packages are from "latest" repository.
Comment 4 Jean-Sébastien Pédron freebsd_committer 2021-04-29 21:16:22 UTC
Hi! Thank you for the report and sorry for the delay in getting back to you.

I tested the following patch from upstream successfuly:
https://github.com/darktable-org/darktable/pull/8775

I now need to figure out the correct process to commit to the new Git repository to push the fix.
Comment 5 commit-hook freebsd_committer 2021-04-29 21:56:16 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=5691fad3cfe1cf9a573fa937d075e081c4f62cbe

commit 5691fad3cfe1cf9a573fa937d075e081c4f62cbe
Author:     Jean-Sébastien Pédron <dumbbell@FreeBSD.org>
AuthorDate: 2021-04-29 21:53:56 +0000
Commit:     Jean-Sébastien Pédron <dumbbell@FreeBSD.org>
CommitDate: 2021-04-29 21:55:19 +0000

    graphics/darktable: Fix OpenEXR detection

    The patch comes from upstream:
    https://github.com/darktable-org/darktable/pull/8775

    It didn't make it to a release yet.

    The package revision is bumped because the build succeeds but darktable
    failed to run with the following error:

        $ darktable --version
        ld-elf.so.1: /usr/local/bin/../lib/darktable/libdarktable.so: Undefined symbol "_ZTIN7Imf_3_09AttributeE"

    With the patch:

        $ darktable --version
        this is darktable 3.4.1
        ...

    PR:             255254
    Reported by:    Ludger Bolmerg <lbolmerg@posteo.de>,
                    Felix Palmen <felix@palmen-it.de>,
                    a.parseg@gmail.com
    Obtained from:  https://github.com/darktable-org/darktable/pull/8775

 graphics/darktable/Makefile                       |  1 +
 graphics/darktable/files/patch-src_CMakeLists.txt | 18 ++++++++++++++++--
 2 files changed, 17 insertions(+), 2 deletions(-)
Comment 6 Jean-Sébastien Pédron freebsd_committer 2021-04-29 21:59:54 UTC
I just pushed the fix. Thank you for the report!