Bug 255396 - emulators/virtualbox-ose-additions: shared clipboard does not work
Summary: emulators/virtualbox-ose-additions: shared clipboard does not work
Status: Closed DUPLICATE of bug 254266
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Virtualbox Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-25 16:10 UTC by bourne.identity@hotmail.com
Modified: 2021-04-25 18:20 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bourne.identity@hotmail.com 2021-04-25 16:10:33 UTC
I am on a Manjaro Linux host with FreeBSD 13.0 RELEASE as the guest.

Bi-directional clipboard does not work for me, even though the setting is enabled in the VirtualBox host.

The shared clipboard simply does not work. I am using VMSVGA as the graphics controller, and my host's VirtualBox complains of Invalid Settings if I try to switch to VBoxSVGA.
Comment 1 Guido Falsi freebsd_committer 2021-04-25 18:20:11 UTC
Yes virtualbox complaints with a scary warning, but it's not really an invalid settings,

Please use VBoxSVGA with 3d acceleration disabled and everything will work fine. Just ignore the warning. This is the best that can be done with the present software.

Maybe it is possible to make clipboard sharing work with VMSVGA work but I'm unable to do that. It requires performing software development on the driver and maybe also in FreeBSD.  3c acceleration bypass can be even more difficult.

At some point this will be documented in the pkg-message.

Marking as duplicate of similar bug report.

*** This bug has been marked as a duplicate of bug 254266 ***