Bug 255399 - games/jaggedalliance2: update to 0.18.0
Summary: games/jaggedalliance2: update to 0.18.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Neel Chauhan
URL: https://ja2-stracciatella.github.io/2...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-25 18:26 UTC by Pavel Timofeev
Modified: 2021-06-01 20:35 UTC (History)
2 users (show)

See Also:


Attachments
port patch (34.40 KB, patch)
2021-04-25 18:26 UTC, Pavel Timofeev
timp87: maintainer-approval+
Details | Diff
port patch new (34.55 KB, patch)
2021-04-26 14:57 UTC, Pavel Timofeev
timp87: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Timofeev 2021-04-25 18:26:04 UTC
Created attachment 224426 [details]
port patch

Update games/jaggedalliance2 to 0.18.0
Comment 1 Fernando Apesteguía freebsd_committer 2021-04-26 13:25:32 UTC
Q/A:  /tmp/255399/games/jaggedalliance2/pkg-plist: You have defined USE_LDCONFIG, but this port does not install any shared objects.

^Triage: Please confirm this change passes QA (portlint, poudriere at least).
--
https://www.freebsd.org/doc/en/books/porters-handbook/testing.html


Thanks!
Comment 2 Pavel Timofeev 2021-04-26 14:57:26 UTC
Created attachment 224446 [details]
port patch new

- fix portlint

[root@13-ports /usr/ports/games/jaggedalliance2]# portlint -AC
looks fine.
Comment 3 commit-hook freebsd_committer 2021-04-26 23:27:52 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=5ec940f106b3c806592f6205540c88a40e91e399

commit 5ec940f106b3c806592f6205540c88a40e91e399
Author:     Neel Chauhan <nc@FreeBSD.org>
AuthorDate: 2021-04-26 23:26:43 +0000
Commit:     Neel Chauhan <nc@FreeBSD.org>
CommitDate: 2021-04-26 23:26:43 +0000

    games/jaggedalliance2: update to 0.18.0

    Changes: https://ja2-stracciatella.github.io/2021/04/23/release-0.18.0.html

    PR:             255399
    Submitted by:   timp87 AT gmail DOT com (maintainer)

 games/jaggedalliance2/Makefile  | 121 ++++++++++++--------
 games/jaggedalliance2/distinfo  | 238 +++++++++++++++++++++++++---------------
 games/jaggedalliance2/pkg-plist |  34 +++++-
 3 files changed, 255 insertions(+), 138 deletions(-)
Comment 4 Neel Chauhan freebsd_committer 2021-04-26 23:28:08 UTC
Committed!
Comment 5 commit-hook freebsd_committer 2021-05-08 10:56:07 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=47bc8ce9dad781c16f1a75cf69e94bf024865c43

commit 47bc8ce9dad781c16f1a75cf69e94bf024865c43
Author:     Tobias Kortkamp <tobik@FreeBSD.org>
AuthorDate: 2021-05-08 08:54:31 +0000
Commit:     Tobias Kortkamp <tobik@FreeBSD.org>
CommitDate: 2021-05-08 10:40:36 +0000

    Revert "games/jaggedalliance2: update to 0.18.0"

    This reverts commit 5ec940f106b3c806592f6205540c88a40e91e399.

    It tries to fetch things during the build.

    ===>  Configuring for ja2-0.18.0
        Updating git repository `https://github.com/selaux/android-ndk-rs`
    warning: spurious network error (2 tries remaining): failed to connect to github.com: Can't assign requested address; class=Os (2)
    warning: spurious network error (1 tries remaining): failed to connect to github.com: Can't assign requested address; class=Os (2)
    error: failed to get `ndk` as a dependency of package `stracciatella v0.1.0 (/wrkdirs/usr/ports/games/jaggedalliance2/work/ja2-stracciatella-0.18.0/rust/stracciatella)`

    Caused by:
      failed to load source for dependency `ndk`

    Caused by:
      Unable to update https://github.com/selaux/android-ndk-rs

    Caused by:
      failed to clone into: /wrkdirs/usr/ports/games/jaggedalliance2/work/cargo-home/git/db/android-ndk-rs-8a286ebb858b1942

    Caused by:
      failed to connect to github.com: Can't assign requested address; class=Os (2)
    *** Error code 101

    If we fix that error it still tries to fetch things later:

    -- Using src='https://github.com/mackron/miniaudio/archive/634cdb028f340075ae8e8a1126620695688d2ac3.zip'
    -- Retrying...
    -- Using src='https://github.com/mackron/miniaudio/archive/634cdb028f340075ae8e8a1126620695688d2ac3.zip'
    -- Retry after 5 seconds (attempt #2) ...
    -- Using src='https://github.com/mackron/miniaudio/archive/634cdb028f340075ae8e8a1126620695688d2ac3.zip'
    -- Retry after 5 seconds (attempt #3) ...
    -- Using src='https://github.com/mackron/miniaudio/archive/634cdb028f340075ae8e8a1126620695688d2ac3.zip'
    -- Retry after 15 seconds (attempt #4) ...
    -- Using src='https://github.com/mackron/miniaudio/archive/634cdb028f340075ae8e8a1126620695688d2ac3.zip'
    -- Retry after 60 seconds (attempt #5) ...
    -- Using src='https://github.com/mackron/miniaudio/archive/634cdb028f340075ae8e8a1126620695688d2ac3.zip'
    CMake Error at /wrkdirs/usr/ports/games/jaggedalliance2/work/.build/dependencies/lib-miniaudio/getter/get-miniaudio-prefix/src/get-miniaudio-stamp/download-get-miniaudio.
    cmake:170 (message):
      Each download failed!

        error: downloading 'https://github.com/mackron/miniaudio/archive/634cdb028f340075ae8e8a1126620695688d2ac3.zip' failed
              status_code: 6
              status_string: "Couldn't resolve host name"
              log:
              --- LOG BEGIN ---
              Could not resolve host: github.com

    PR:             255399

 games/jaggedalliance2/Makefile  | 121 ++++++++------------
 games/jaggedalliance2/distinfo  | 238 +++++++++++++++-------------------------
 games/jaggedalliance2/pkg-plist |  34 +-----
 3 files changed, 138 insertions(+), 255 deletions(-)
Comment 6 Pavel Timofeev 2021-06-01 20:35:18 UTC
This was an incomplete attempt and it was rollbacked.
See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256355 for second attempt to update this patch