Bug 255400 - graphics/ufraw: Fixes for several options and some other stuff
Summary: graphics/ufraw: Fixes for several options and some other stuff
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Rodrigo Osorio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-25 19:21 UTC by Rainer Hurling
Modified: 2021-05-08 11:49 UTC (History)
0 users

See Also:
rhurlin: maintainer-feedback? (rodrigo)


Attachments
Fixes for several options (2.27 KB, patch)
2021-04-25 19:21 UTC, Rainer Hurling
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Hurling freebsd_committer 2021-04-25 19:21:17 UTC
Created attachment 224427 [details]
Fixes for several options

Thanks for the update of graphics/ufraw to version 0.22.20210424.


Because I got an installation error, when I tried to build and install outside of Poudriere with all options enabled, I investigated a bit ;)  This is wht I found and tried to solve:

(1) When building and installing on a real box (not in Poudriere), it turned out that the EXIV2 and LENSFUN options are installed even when disabled, if the associated libraries are already present on the system. Both can be solved by manipulating configure.ac in such a way that already installed libraries are not found (if options disabled).

(2) The FITS option, on the other hand, wasn't installed in the enabled state.

(3) ufraw.schemas (in option GNOME) could not be installed because share/gconf/schemas was used instead of etc/gconf/schemas.

(4) In the CONFIGURE_ARGS I added --enable-jasper, because otherwise the port cannot use JPEG2000 files.

(5) Since it was not clear to me what use PC_FALSE has in the options VARS, I removed these lines (as a suggestion, of course).

(6) The GIMP option was missing several dependencies and an entry in pkg-plist, which Poudriere found while in test mode.

(7) I did not do the suggestion of 'portclippy' to reorder several Makefile entries, as is the convention on FreeBSD. This would have made my other changes more confusing ...


In the attachment area you will find a patch, which includes a working patch. All options can be disabled or enabled now without any error, I think. Hope this is useful for you :)
Comment 1 commit-hook freebsd_committer 2021-05-08 11:42:17 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=c6ffec1fc8cfc146ad0eee524653d8a0dd3a487b

commit c6ffec1fc8cfc146ad0eee524653d8a0dd3a487b
Author:     Rodrigo Osorio <rodrigo@FreeBSD.org>
AuthorDate: 2021-05-07 16:08:05 +0000
Commit:     Rodrigo Osorio <rodrigo@FreeBSD.org>
CommitDate: 2021-05-08 13:39:41 +0000

    graphics/ufraw: Update ufraw configuration

     * Add --enable-jasper option to enable JPEG2000 support
     * Remove old/deprecate elements such as PC_FALSE not used anymore
     * Fix some optional configuration parameters
     * Add post-patch actions to modify configure.ac if some options
       are disabled. For some reasons, even if the option is 'disabled'
       the configure auto activates the the option if the required lib is installed.
     * Add missing dependencies for GIMP option
     * lint with portfmt and portclippy

    PR:             255400
    Reported by:    rhurlin

 graphics/ufraw/Makefile  | 80 ++++++++++++++++++++++++++++--------------------
 graphics/ufraw/pkg-plist |  1 +
 2 files changed, 48 insertions(+), 33 deletions(-)
Comment 2 Rodrigo Osorio freebsd_committer 2021-05-08 11:49:45 UTC
Committed, thanks for the work done on this port, I really appreciate it.

For the record, PC_FALSE are variables added a long time ago to change the Makefine behaviors