Bug 255407 - sysutils/znapzend: 0.20.0_1 package not working on FreeBSD 13
Summary: sysutils/znapzend: 0.20.0_1 package not working on FreeBSD 13
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jimmy Olgeni
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-26 05:48 UTC by stephan
Modified: 2021-04-28 06:00 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (olgeni)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stephan 2021-04-26 05:48:47 UTC
v0.20.0_1 stopped working after upgrading to FreeBSD 13 and upgrading packages to latest quarterly in turn.

$ sudo /usr/local/etc/rc.d/znapzend start
Starting znapzend.
Can't locate Mojo/Base.pm in @INC (you may need to install the Mojo::Base module) (@INC contains: /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/site_perl/mach/5.32 /usr/local/lib/perl5/5.32/mach /usr/local/lib/perl5/5.32) at /usr/local/lib/perl5/site_perl/ZnapZend.pm line 3.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/ZnapZend.pm line 3.
Compilation failed in require at /usr/local/bin/znapzend line 9.
BEGIN failed--compilation aborted at /usr/local/bin/znapzend line 9.
/usr/local/etc/rc.d/znapzend: WARNING: failed to start znapzend

$ pkg info znapzend
znapzend-0.20.0_1
Name           : znapzend
Version        : 0.20.0_1
Installed on   : Mon Apr 26 07:24:11 2021 CEST
Origin         : sysutils/znapzend
Architecture   : FreeBSD:13:*
Prefix         : /usr/local
Categories     : sysutils
Licenses       : GPLv3+
Maintainer     : olgeni@FreeBSD.org
WWW            : https://www.znapzend.org/
Comment        : ZFS-centric backup tool
Annotations    :
	repo_type      : binary
	repository     : FreeBSD
Flat size      : 209KiB
Description    :
ZnapZend is a ZFS centric backup tool.
It relies on snapshot, send and recieve to do its work.
It has the built-in ability to manage both local
snapshots as well as remote copies by thinning them out
as time progresses.

The ZnapZend configuration is stored as properties in
the ZFS filesystem itself.

WWW: https://www.znapzend.org/


I also created this at https://github.com/oetiker/znapzend/issues/544 before I noticed that there already have been fixes to the port due to Mojo issues.
Comment 1 stephan 2021-04-26 06:06:48 UTC
P.S.:

$ pkg info | grep Mojo
p5-Mojo-IOLoop-Delay-8.76      Flow-control helpers for Mojo::Promise
p5-Mojo-IOLoop-ForkCall-0.21   Run blocking functions asynchronously by forking
p5-Mojolicious-9.15            High-level MVC web framework written in Perl
Comment 2 stephan 2021-04-28 06:00:25 UTC
Found problem: Mojo package was not correctly installed for whatever reason, after reinstalling all dependencies znapzend is starting now.