Bug 255440 - math/R: liblzma library and headers are required
Summary: math/R: liblzma library and headers are required
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Joseph Mingrone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-27 13:25 UTC by Gian-Simon Purkert
Modified: 2021-04-30 16:10 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (jrm)


Attachments
Config log from work-folder (484.84 KB, text/plain)
2021-04-27 13:25 UTC, Gian-Simon Purkert
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gian-Simon Purkert 2021-04-27 13:25:28 UTC
Created attachment 224471 [details]
Config log from work-folder

Build with make i get that error:

checking for lzma_version_number in -llzma... no
configure: error: "liblzma library and headers are required"
===>  Script "configure" failed unexpectedly.
Please report the problem to jrm@FreeBSD.org [maintainer] and attach the
"/usr/ports/math/R/work/R-4.0.5/config.log" including the output of the failure
of your make command. Also, it might be a good idea to provide an overview
of all packages installed on your system (e.g. a /usr/local/sbin/pkg-static
info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/math/R
*** Error code 1
Comment 1 Joseph Mingrone freebsd_committer 2021-04-28 02:05:46 UTC
Are you building with the default options?  I can't reproduce this in a clean 12.2 poudriere jail with a few different option combinations.

http://pkg.awarnach.mathstat.dal.ca/data/122amd64-default/2021-04-27_13h48m13s/logs/R-4.0.5_1.log

http://pkg.awarnach.mathstat.dal.ca/data/122amd64-default/2021-04-27_22h27m27s/logs/R-4.0.5_1.log

http://pkg.awarnach.mathstat.dal.ca/data/122amd64-default/2021-04-27_22h37m29s/logs/R-4.0.5_1.log

Could you share the list of installed packages and the options you are using?  How are you building?
Comment 2 Gian-Simon Purkert 2021-04-28 11:06:22 UTC
Not the defaults, the options are in the Config log attachment.

I would say that for one of the options liblzma library and headers are required to build it.

Build with make like i wrote.
Comment 3 Gian-Simon Purkert 2021-04-28 11:35:35 UTC
Better readable options list:

FLANG=off: Use experimental flang Fortran compiler
ICU=on: Unicode support via ICU
INFO=on: Build and/or install GNU info pages
LDOUBLE=on: Long double data type
LETTER=off: US letter paper
MEMPROF=off: Memory profiling via Rprofmem() and tracemem()
NLS=on: Native Language Support
OPENMP=on: Parallel processing support via OpenMP
RPROF=on: R profiling via Rprof()
X11=on: X11 graphics device
CAIROPANGO=on: Cairo graphics device and Pango multi-language text
GHOSTSCRIPT=on: Graphics device for bitmap files via Ghostscript
JPEG=on: JPEG graphics device
PNG=on: PNG graphics device
TCLTK=on: Tcl/Tk GUI toolkit support
TEXDOCS=off: Build/Install TeX-dependent documentation files
TIFF=on: TIFF image format support
ATLAS=off: ATLAS blas implementation
NETLIB=on: Netlib BLAS implementation
OPENBLAS=off: OpenBLAS blas implementation
RBLAS=off: Use R-bundled BLAS implementation
Comment 4 Joseph Mingrone freebsd_committer 2021-04-29 16:31:39 UTC
I still can't reproduce this with your port options.

http://pkg.awarnach.mathstat.dal.ca/data/122amd64-default/2021-04-29_12h21m16s/logs/R-4.0.5_1.log

liblzma is part of the base system on 12.2 (/usr/include/lzma.h and /usr/lib/liblzma.so).  Maybe you have archivers/lzmalib port installed and it conflicts by not offering the functionality that R's configure script is looking for?  I can't tell because you didn't share your installed packages.
Comment 5 Gian-Simon Purkert 2021-04-30 08:39:32 UTC
(In reply to Joseph Mingrone from comment #4)

>Maybe you have archivers/lzmalib port installed and it conflicts by not offering the functionality that R's configure script is looking for?  I can't tell because you didn't share your installed packages.

It was exactly that! Thanks for the help.

Have a great Day
Comment 6 Joseph Mingrone freebsd_committer 2021-04-30 16:10:34 UTC
Great.  Thanks for the follow-up.  Credit to ashish@ for suggesting this might be the cause of the issue.  I might add a CONFLICTS so others don't hit this problem.