Bug 255463 - archivers/lzip: Update to 1.22
Summary: archivers/lzip: Update to 1.22
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-28 14:12 UTC by Gian-Simon Purkert
Modified: 2021-05-11 06:20 UTC (History)
2 users (show)

See Also:


Attachments
Update to 1.22 (1.16 KB, patch)
2021-04-28 14:12 UTC, Gian-Simon Purkert
no flags Details | Diff
Update to 1.22 Rev. (1.33 KB, patch)
2021-05-04 14:54 UTC, Gian-Simon Purkert
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gian-Simon Purkert 2021-04-28 14:12:36 UTC
Created attachment 224500 [details]
Update to 1.22
Comment 1 Gian-Simon Purkert 2021-04-28 14:15:15 UTC
lzip-1.22/NEWS

Changes in version 1.22:

Lzip now reports an error if a file name is empty (lzip -t "").

Option '-o, --output' now behaves like '-c, --stdout', but sending the
output unconditionally to a file instead of to standard output. See the new
description of '-o' in the manual. This change is backwards compatible only
when (de)compressing from standard input alone. Therefore commands like:
  lzip -o foo.lz - bar < foo
must now be split into:
  lzip -o foo.lz - < foo
  lzip bar
or rewritten as:
  lzip - bar < foo > foo.lz

When using '-c' or '-o', lzip now checks whether the output is a terminal
only once.

Lzip now does not even open the output file if the input file is a terminal.

Lzip can now be built, tested, and installed on systems lacking a 'make'
program. (Feature suggested by Mohammad Akhlaghi).

The words 'decompressed' and 'compressed' have been replaced with the
shorter 'out' and 'in' in the verbose output when decompressing or testing.

Option '--list' now reports corruption or truncation of the last header in a
multimenber file specifically instead of showing the generic message "Last
member in input file is truncated or corrupt."

The commands needed to extract files from a tar.lz archive have been
documented in the manual, in the output of '--help', and in the man page.

Plzip and tarlz are mentioned in the manual as alternatives for
multiprocessors.

Several fixes and improvements have been made to the manual.

9 new test files have been added to the testsuite.
Comment 2 Gerald Pfeifer freebsd_committer 2021-04-28 18:58:50 UTC
Thank you, Gian-Simon. I'll need a few days, but appreciate your note
and the update and will test and commit it.
Comment 3 Gian-Simon Purkert 2021-04-28 19:59:29 UTC
(In reply to Gerald Pfeifer from comment #2)

Hy Gerald, no need to hurry.

Have a great Day.
Comment 4 daniel.engberg.lists 2021-04-29 07:37:36 UTC
PORTVERSION --> DISTVERSION
https://www-legacy.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/book.html#porting-makefile and
"Table 5.2. Package Naming Examples" in Porters Handbook

LICENSE_FILE entry is missing
https://www-legacy.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/book.html#licenses

Upstream doesn't use GNU CONFIGURE and therefore Makefile should use HAS_CONFIGURE which also removes compilation warning
"6.5.3. configure Script" in Porters Handbook

Best regards,
Daniel
Comment 5 Gian-Simon Purkert 2021-05-04 14:54:50 UTC
Created attachment 224661 [details]
Update to 1.22 Rev.

-Changed to Distversion
-Has_Configure
-Added license-file location
-Added missing plist entry's (info-files)

Thanks Daniel for the QA and the Hints
Comment 6 Gerald Pfeifer freebsd_committer 2021-05-11 06:02:42 UTC
(In reply to Gian-Simon Purkert from comment #5)
> Update to 1.22 Rev.
>
> -Changed to Distversion
> -Has_Configure
> -Added license-file location
> -Added missing plist entry's (info-files)

This does not pass my testing:

# make package
===>  Building package for lzip-1.22
pkg: Unable to access file .../stage/scratch/tmp/gerald/lzip-prefix/bin/lzip:No such file or directory
pkg: Unable to access file .../stage/scratch/tmp/gerald/lzip-prefix/share/info/dir:No such file or directory
pkg: Unable to access file .../stage/scratch/tmp/gerald/lzip-prefix/share/info/lzip.info:No such file or directory
pkg: Unable to access file .../stage/scratch/tmp/gerald/lzip-prefix/share/man/man1/lzip.1.gz:No such file or directory
*** Error code 1

And the last part is an indication that there is something wrong -
info-files are already taken care of by INFO=lzip .

This is caused by the move from GNU_CONFIGURE to HAS_CONFIGURE. There
are two options to address that: Keep GNU_CONFIGURE, since what this
ports includes is pretty much that.

Or switch to HAS_CONFIGURE, in which case it appears we need to add
--prefix=${PREFIX} --mandir=${MANPREFIX}/man to CONFIGURE_ARGS at least.
I prefer the former at this point.

(See the description of CONFIGURE_ARGS in Mk/bsd.ports.mk on the different
consequences GNU_CONFIGURE and HAS_CONFIGURE have for a bit of context.)
Comment 7 commit-hook freebsd_committer 2021-05-11 06:16:59 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=cc8dacaaf0304e8decf8e7f9daa43bc0a8a46a83

commit cc8dacaaf0304e8decf8e7f9daa43bc0a8a46a83
Author:     Gerald Pfeifer <gerald@FreeBSD.org>
AuthorDate: 2021-05-11 06:16:03 +0000
Commit:     Gerald Pfeifer <gerald@FreeBSD.org>
CommitDate: 2021-05-11 06:16:03 +0000

    archivers/lzip: Update to 1.22

    This includes the following changes:
     - Report an error if a file name is empty.
     - Make '-o' behave like '-c', but writing to file instead of stdout.
     - Do not open output if input is a terminal.
     - Replace 'decompressed', 'compressed' with 'out', 'in' in output.
     - Several fixes and improvements, improved test coverage.

    On the way switch from PORTVERSION to DISTVERSION and add a LICENSE_FILE
    (while the license itselfs does not change from GPLv2).

    PR:             255463
    Submitted by:   Gian-Simon Purkert <gspurki@gmail.com>

 archivers/lzip/Makefile | 3 ++-
 archivers/lzip/distinfo | 6 +++---
 2 files changed, 5 insertions(+), 4 deletions(-)
Comment 8 Gerald Pfeifer freebsd_committer 2021-05-11 06:20:43 UTC
Thanks for your submission, Gian-Simon, and suggestions, Daniel!