Bug 255482 - print/lilypond: update to 2.22.1
Summary: print/lilypond: update to 2.22.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Rainer Hurling
URL: http://lilypond.org/news.html#LilyPon...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-29 12:27 UTC by m.ne
Modified: 2021-05-02 05:02 UTC (History)
1 user (show)

See Also:


Attachments
patch for print/lilypond to 2.22.1 (882 bytes, patch)
2021-04-29 12:27 UTC, m.ne
m.ne: maintainer-approval+
Details | Diff
updated patch (1.17 KB, patch)
2021-04-30 18:24 UTC, m.ne
m.ne: maintainer-approval+
Details | Diff
updated patch 2 (1.75 KB, patch)
2021-05-01 10:49 UTC, m.ne
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description m.ne 2021-04-29 12:27:03 UTC
Created attachment 224523 [details]
patch for print/lilypond to 2.22.1

Update to 2.22.1
Comment 1 Rainer Hurling freebsd_committer 2021-04-29 17:29:48 UTC
Thanks for the patch.


When testing with Poudriere, the following error occurs in the configure phase, when the NLS option is disabled:

ERROR: Please install required programs:  msgfmt


Can you please investigate where the cause of this error?  Many thanks :)
Comment 2 m.ne 2021-04-30 18:24:35 UTC
Created attachment 224578 [details]
updated patch
Comment 3 m.ne 2021-04-30 18:27:39 UTC
(In reply to Rainer Hurling from comment #1)
Thanks for starting to work on the update. Please have a look again.
Comment 4 Rainer Hurling freebsd_committer 2021-05-01 07:21:52 UTC
The new patch builds and installs fine on Poudriere, in several combinations of the options :)

On my real life box, I stumbled upon not being able to install GUILE2 with the option disabled. In this case, the port tries to install GUILE 1, which conflicts with an existing GUILE2 installation. So in such cases the GUILE2 option must be used.

Maybe the option description should indicate a bit more clearly that either GUILE or GUILE2 will be installed? For example:

-GUILE2_DESC=	Use guile2 (will incur some performance penalty)
+GUILE2_DESC=	guile2 instead guile (incurs performance penalty)


A second point is ImageMagick. The current version is 7.0.11-10. Lilypond builds and installs fine with version 7, also on Poudriere. As far as I understand, ImageMagick only uses convert. 

Would there be anything against changing ImageMagick from 6 to 7? Version 7 is now much more common even in the FreeBSD ports ...
Comment 5 m.ne 2021-05-01 10:49:06 UTC
Created attachment 224591 [details]
updated patch 2
Comment 6 m.ne 2021-05-01 10:57:31 UTC
(In reply to Rainer Hurling from comment #4)
I did both changes in a new patch.

The reason for the GUILE2 option indeed was to offer a possibility to use lilypond with guile2 already installed (via a request off-list).

The dependency on ImageMagick6 already existed when I "inherited" the port and as there were no actual problems, I never bothered to change it. Consolidating towards the more actively maintained version seems to be a good thing, though.
Comment 7 Rainer Hurling freebsd_committer 2021-05-01 16:27:04 UTC
(In reply to m.ne from comment #6)

Thanks for your fast reply and the updated patch. QA seems ok.

If you agree, I could commit now ;)
Comment 8 m.ne 2021-05-01 20:56:33 UTC
(In reply to Rainer Hurling from comment #7)
If have no objections, please go ahead. Thanks.
Comment 9 commit-hook freebsd_committer 2021-05-02 04:57:19 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=c505ebee4554490a2ef3b284e01f43e616a8c079

commit c505ebee4554490a2ef3b284e01f43e616a8c079
Author:     Rainer Hurling <rhurlin@FreeBSD.org>
AuthorDate: 2021-05-02 04:54:39 +0000
Commit:     Rainer Hurling <rhurlin@FreeBSD.org>
CommitDate: 2021-05-02 04:54:39 +0000

    print/lilypond: Update to 2.22.1

    https://lilypond.org/news.html#LilyPond-2_002e22_002e1-released-April-25_002c-2021

    PR:             255482
    Submitted by:   m.ne@gmx.net (maintainer)

 print/lilypond/Makefile  |  8 +++----
 print/lilypond/distinfo  |  6 +++---
 print/lilypond/pkg-plist | 54 ++++++++++++++++++++++++------------------------
 3 files changed, 34 insertions(+), 34 deletions(-)
Comment 10 Rainer Hurling freebsd_committer 2021-05-02 05:02:58 UTC
Committed, thanks :)

In pkg-plist, I had to change %%PYTHON_SUFFIX%% into %%PYTHON_EXT_SUFFIX%%, to get it more robust for different Python versions. While here, I also ordered the URW entries.