Bug 255555 - devel/py-prettyprinter: Fix pytest-runner dependency
Summary: devel/py-prettyprinter: Fix pytest-runner dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: Neel Chauhan
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-05-02 21:27 UTC by Patrice Clement
Modified: 2021-05-06 01:17 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+
koobs: merge-quarterly-


Attachments
py-prettyprinter-update-dependencies.patch (995 bytes, patch)
2021-05-02 21:27 UTC, Patrice Clement
no flags Details | Diff
Proposed patch for fixing the build (913 bytes, application/mbox)
2021-05-03 02:20 UTC, Neel Chauhan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrice Clement 2021-05-02 21:27:19 UTC
Created attachment 224619 [details]
py-prettyprinter-update-dependencies.patch

Hi

I've been getting a lot of reports from pkg-fallout@ wrt py-prettyprinter build failures. For instance: http://beefy15.nyi.freebsd.org/data/130i386-default/0ae18b07e470/logs/py38-prettyprinter-0.18.0.log

The package always fail with the same error:

distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('pytest-runner==3.0')

This is a weird error since the package builds just fine on my FreeBSD server and even on my FreeBSD laptop. I believe the deps are wrong and haven't been properly updated in bug 255274 (apologies I should have been more careful when reviewing the patch). See attached patch for a proper update of the package dependencies.

Please review and merge accordingly.

Thanks!
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-05-03 01:52:13 UTC
^Triage: Assign bug 255274 committer 

Ports cannot robustly support == dependencies. They need to be adjusted, ideally upstream in the long-term, to >= dependencies.

See: https://wiki.freebsd.org/Python/PortsPolicy#Dependencies
Comment 2 Neel Chauhan freebsd_committer 2021-05-03 01:54:31 UTC
Sure, LGTM.

Who should commit, me or koobs@.
Comment 3 Neel Chauhan freebsd_committer 2021-05-03 01:55:33 UTC
NVM, I'll commit.
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2021-05-03 01:58:38 UTC
Modifying *_DEPENDS is insufficient. *_DEPENDS lines *must* match (exactly) those defined in the upstream package metadata, or that metadata needs to be modified (eg: s/==/>=)

However, when modifying upstream dependency version specs, extensive QA must be run (test suites especially) to ensure they work correctly with other/later/different versions. These version spec issues and changes should be sent upstream for correct and permanent resolution
Comment 5 Neel Chauhan freebsd_committer 2021-05-03 02:20:59 UTC
Created attachment 224625 [details]
Proposed patch for fixing the build

I have a proposed patch which removes the hard dependency on pytest-runner==3.0. This passes poudriere tests.
Comment 6 Patrice Clement 2021-05-04 15:06:04 UTC
(In reply to Neel Chauhan from comment #5)
Hi! Feel free to go ahead and apply whatever patch which solves this problem. I don't have your expertise on the matter! ;)
Comment 7 commit-hook freebsd_committer 2021-05-04 16:30:19 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=46ee17ded040af73e358ad2c15d84a39728c3b32

commit 46ee17ded040af73e358ad2c15d84a39728c3b32
Author:     Neel Chauhan <nc@FreeBSD.org>
AuthorDate: 2021-05-04 16:27:53 +0000
Commit:     Neel Chauhan <nc@FreeBSD.org>
CommitDate: 2021-05-04 16:29:12 +0000

    devel/py-prettyprinter: Fix pytest-runner dependency

    PR:             255555
    Reported by:    Patrice Clement <monsieurp@gentoo.org> (maintainer)

 devel/py-prettyprinter/files/patch-setup.py (new) | 11 +++++++++++
 1 file changed, 11 insertions(+)
Comment 8 Neel Chauhan freebsd_committer 2021-05-04 16:38:07 UTC
Committed!

I don't think this needs to be merged into quarterly since 2021Q2 still has the old version.
Comment 9 Kubilay Kocak freebsd_committer freebsd_triage 2021-05-05 02:31:47 UTC
MFH: No (quarterly unaffected)
Comment 10 Patrice Clement 2021-05-05 14:10:34 UTC
Hi! I keep getting emails from pkg-fallout@ even after the latest fix. See http://beefy9.nyi.freebsd.org/data/114amd64-default/e67ae562eb4c/logs/py38-prettyprinter-0.18.0.log ! :(
Comment 11 Kubilay Kocak freebsd_committer freebsd_triage 2021-05-06 01:13:52 UTC
This is/was a runtime failure and the commit didn't bump the PORTREVISION, so the port was not rebuilt
Comment 12 Neel Chauhan freebsd_committer 2021-05-06 01:16:20 UTC
Committed!
Comment 13 Neel Chauhan freebsd_committer 2021-05-06 01:16:49 UTC
@koobs thanks for pointing out. Sorry for too many messages.
Comment 14 commit-hook freebsd_committer 2021-05-06 01:17:10 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=44eddfbf64c56fe74c4fe0aa843a5004aab54134

commit 44eddfbf64c56fe74c4fe0aa843a5004aab54134
Author:     Neel Chauhan <nc@FreeBSD.org>
AuthorDate: 2021-05-06 01:15:19 +0000
Commit:     Neel Chauhan <nc@FreeBSD.org>
CommitDate: 2021-05-06 01:15:19 +0000

    devel/py-prettyprinter: Bump PORTREVISION

    This allows the port to be rebuilt as per the fix in commit
    46ee17ded040af73e358ad2c15d84a39728c3b32.

    PR:     255555

 devel/py-prettyprinter/Makefile | 1 +
 1 file changed, 1 insertion(+)