Bug 255558 - No IPv4/ARP traffic on vlan interface when using IntX.Y notation, vlanXY works
Summary: No IPv4/ARP traffic on vlan interface when using IntX.Y notation, vlanXY works
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.2-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-net (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-03 00:03 UTC by Daniel Hoffmann
Modified: 2021-05-10 10:37 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Hoffmann 2021-05-03 00:03:46 UTC
Hi,

when using 'ifconfig bge0.60 create' / 'ifconfig bge0.60 vlan 60 vlandev bge0 up', i only see ARP and ipv6 traffic on the interface, but no IPv4 nor DHCP replies. Verified by using tcpdump on the parent and the vlan interface, switchport config Untagged/Tagged(60)

using tagged only on bge1, there is the same behavior:
ifconfig bge1 up
ifconfig bge1.10 create vlan 10 vlandev bge1 up
ifconfig bge1.60 create vlan 60 vlandev bge1 up

bge1.10 -> everything ok, dhcp&ipv4 flows in and out
bge1.60 -> only arp&ipv6 traffic show up in tcpdump

After using 'ifconfig vlan60 create / 'ifconfig vlan60 vlan 60 vlandev bge0 up', the whole traffic passes the interfaces, still using bge1.10 for vlanid 10.

System:
12.2-RELEASE-p6 FreeBSD 12.2-RELEASE-p6 GENERIC  amd64

best regards
Daniel
Comment 1 Daniel Hoffmann 2021-05-10 08:19:20 UTC
I tried the same steps with FreeBSD-14.0-CURRENT-amd64-20210429-b9820bca183-246384-mini-memstick.img and could NOT reproduce this.

please close this pr.


best regards
Daniel