Bug 255572 - Unable to mount hard drive (hdd: not found)
Summary: Unable to mount hard drive (hdd: not found)
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 13.0-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-03 16:45 UTC by hunter0one
Modified: 2021-05-06 06:18 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hunter0one 2021-05-03 16:45:03 UTC
I recently moved to FreeBSD from Devuan Linux and hit a snag. My computer has an SSD which I install the operating system to and I also have a 1 TB hard drive which I typically mounted to /hdd on Linux for storing videos and other things. I tried to do the same on FreeBSD, formatting both my SSD and HDD with ZFS and mounting the hard drive to /hdd, but when I booted for the first time afterwards the init stopped as it said "hdd: no such file or directory" (or something similar, I'm posting this a day afterwards).

It prompted for me to use the shell so I did and checked /etc/fstab. This is what it looked like (the values didnt align with the # comments due to the letter length of the devices so apologies if its hard to read):

# Device	Mountpoint	FStype	Options	Dump	Pass#
root   	/		zfs	rw	0	0
/dev/ada0p3	none		swap	sw	0	0
hdd    /hdd            zfs      rw      0       0       0

I tried to change the device name (hdd) to /dev/ada1p1, but then it said that /dev/ada1p1 could not be found. Checking in /dev/, the file ada1p1 does in fact exist. I eventually removed the entry altogether so that I could boot into my new system, but I can't mount my hard drive at all. I tried to mount it via the terminal and it gives the same error (it couldnt be found).

It seems like its not a ZFS-specific issue, it appears this person has the same problem with UFS: https://forums.freebsd.org/threads/my-freebsd-system-is-unable-to-mount-a-hard-drive-and-is-saying-that-the-file-isnt-there-even-though-it-is.79142/
Comment 1 Yuri Pankov freebsd_committer 2021-05-03 16:58:49 UTC
Please ask support questions on relevant mailing lists, e.g.: https://lists.freebsd.org/mailman/listinfo/freebsd-questions (and not in bugtracker).

You don't (usually) have to add anything to fstab for ZFS so make sure you are familar with ZFS concepts: https://docs.freebsd.org/en/books/handbook/zfs/.