Bug 255677 - mail/postfix build failure
Summary: mail/postfix build failure
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Juraj Lutter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-07 07:36 UTC by oz42
Modified: 2021-06-12 22:12 UTC (History)
8 users (show)

See Also:
bugzilla: maintainer-feedback? (otis)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oz42 2021-05-07 07:36:48 UTC
--- tls_misc.o ---
/usr/local/libexec/ccache/world/cc -fPIC -I. -I../../include -DDEF_CONFIG_DIR=\"/usr/local/etc/postfix\" -DDEF_DAEMON_DIR=\"/usr/local/libexec/postfix\" -DDEF_META_DIR=\"/usr/local/libexec/postfix\" -DDEF_COMMAND_DIR=\"/usr/local/sbin\" -DDEF_SENDMAIL_PATH=\"/usr/local/sbin/sendmail\" -DDEF_NEWALIAS_PATH=\"/usr/local/bin/newaliases\" -DDEF_MAILQ_PATH=\"/usr/local/bin/mailq\" -DDEF_MANPAGE_DIR=\"/usr/local/man\" -DDEF_README_DIR=\"no\" -DDEF_HTML_DIR=\"no\" -DDEF_QUEUE_DIR=\"/var/spool/postfix\" -DDEF_DATA_DIR=\"/var/db/postfix\" -DDEF_MAIL_OWNER=\"postfix\" -DDEF_SGID_GROUP=\"maildrop\" -Wmissing-prototypes -Wformat -Wno-comment -DUSE_SASL_AUTH -DHAS_EAI -I/usr/local/include -DNO_PCRE -DDEF_SERVER_SASL_TYPE=\"dovecot\" -DUSE_TLS -I/usr/local/include -I/usr/local/include/db5 -I/usr/local/include -DHAS_DEV_URANDOM -DDEF_SHLIB_DIR=\"/usr/local/lib/postfix\" -DUSE_DYNAMIC_LIBS -DUSE_DYNAMIC_MAPS -Wmissing-prototypes -Wformat -Wno-comment -fno-common -fPIC  -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -I. -I../../include -DFREEBSD12 -c tls_misc.c
tls_misc.c:331:31: error: use of undeclared identifier 'TLS1_3_VERSION'

make[4]: stopped in /usr/ports/mail/postfix/work/postfix-3.6.0/src/tls
Comment 1 oz42 2021-05-07 07:37:09 UTC
My /etc/make.conf:

OPTIONS_UNSET= NIS
OPTIONS_UNSET+= X11
OPTIONS_UNSET+= DOCS
OPTIONS_UNSET+= DEBUG
OPTIONS_UNSET+= WAYLAND
#
DEFAULT_VERSIONS+= ssl=libressl
Comment 2 Peter Putzer 2021-05-08 12:59:29 UTC
I've noticed this as well. I think the TLS support in postfix does not like LibreSSL.
Comment 3 oz42 2021-05-17 07:14:32 UTC
(In reply to Peter Putzer from comment #2)
It used to work with previous postfix releases 3.5.x
Comment 4 Peter Putzer 2021-05-19 20:41:41 UTC
(In reply to oz42 from comment #3)

Yes, but 3.6 requires the OpenSSL 1.1.1 API, which LibreSSL currently does not provide in full.
Comment 5 Li-Wen Hsu freebsd_committer 2021-06-01 05:01:20 UTC
Over to new maintainer