Bug 255690 - cad/PrusaSlicer: 3D view not rendered
Summary: cad/PrusaSlicer: 3D view not rendered
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL: https://github.com/prusa3d/PrusaSlice...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-07 20:22 UTC by a.parseg
Modified: 2021-08-04 16:41 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (teodorsigaev)


Attachments
Ugly fix (526 bytes, patch)
2021-05-11 12:19 UTC, teodorsigaev@gmail.com
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description a.parseg 2021-05-07 20:22:22 UTC
As described in https://github.com/prusa3d/PrusaSlicer/issues/6396

At startup, the 3D view is not rendered and the underlying background is left visible. The application remains responsive and can be closed normally. On the command line, it reports a series of

[(timestamp)] [0x0000000806012000] [error]   Unable to init glew library

uname -a
FreeBSD thorium 13.0-RELEASE FreeBSD 13.0-RELEASE #0 releng/13.0-n244733-ea31abc261f: Fri Apr  9 04:24:09 UTC 2021     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/amd64.amd64/sys/GENERIC  amd64

PrusaSlicer-2.3.0_4
Name           : PrusaSlicer
Version        : 2.3.0_4
Installed on   : Fri May  7 22:13:56 2021 CEST
Origin         : cad/PrusaSlicer
Architecture   : FreeBSD:13:amd64
Comment 1 teodorsigaev@gmail.com 2021-05-11 12:19:07 UTC
Created attachment 224841 [details]
Ugly fix

Seems, it;s a bug of wxWidget 3.1.5? current head is already fixed. 
https://github.com/supermerill/SuperSlicer/issues/1093

I found only ugly hack which fixes the problem but I don't intend to suggest to commit.

BTW, the same problem there is in new 2.3.1 version of PrusaSlicer, which I suggested to commit ( https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=255363 )
Comment 2 Michael Reifenberger freebsd_committer 2021-07-30 19:43:04 UTC
The fix works for me too.
Even if the fix is quite ugly maybe it should get committed as a workaround
until upstream fixes the root cause.

The alternative is a non working prusa-slicer...
Comment 3 a.parseg 2021-08-02 17:53:54 UTC
Works here too. 

Patched and locked waiting for a long-term fix.
Comment 4 commit-hook freebsd_committer 2021-08-04 16:40:59 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=b519599f37853728e94aba3d2c3c9d0d1022a512

commit b519599f37853728e94aba3d2c3c9d0d1022a512
Author:     Fernando Apesteguía <fernape@FreeBSD.org>
AuthorDate: 2021-08-04 09:58:32 +0000
Commit:     Fernando Apesteguía <fernape@FreeBSD.org>
CommitDate: 2021-08-04 16:36:02 +0000

    cad/PrusaSlicer: 3D view not rendered

    Apply a hack to fix this issue until this is sorted out upstream.

    Bump PORTREVISION

    See https://github.com/prusa3d/PrusaSlicer/issues/6396

    PR:     255690
    Reported by:    a.parseg@gmail.com
    Tested by:      a.parseg@gmail.com, mr@, teodorsigaev@gmail.com

 cad/PrusaSlicer/Makefile                                     |  2 +-
 .../files/patch-src_slic3r_GUI_OpenGLManager.cpp (new)       | 12 ++++++++++++
 2 files changed, 13 insertions(+), 1 deletion(-)
Comment 5 Fernando Apesteguía freebsd_committer 2021-08-04 16:41:52 UTC
Worked for me too.

We will remove the patch when upstream fixes the issue.

Thanks!