Bug 255721 - x11/guake: Fails to run on Python 3.8: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NameHasNoOwner | ServiceUnknown
Summary: x11/guake: Fails to run on Python 3.8: dbus.exceptions.DBusException: org.fre...
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-patch, needs-qa
: 257519 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-05-09 07:22 UTC by Xevi
Modified: 2021-08-01 09:44 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (daniel)


Attachments
output (170.05 KB, image/png)
2021-05-09 07:22 UTC, Xevi
no flags Details
x11/guake patch (16.10 KB, patch)
2021-08-01 09:44 UTC, Daniel Shafer
daniel: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Xevi 2021-05-09 07:22:04 UTC
Created attachment 224788 [details]
output

Description:
Guake fails to start. When I start it i get the output of the attachment image.

Seems that the problem is because of the code of the guake port is outdated and don't works with python3.8. On the last guake release on github it's fixed 

https://github.com/Guake/guake/blob/master/guake/utils.py
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-06-02 00:11:48 UTC
This doesn't appear to be (either only, or at all) a 'Python 3.8 support' issue.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2021-06-02 00:12:10 UTC
See also: https://bugs.gentoo.org/667878  (can
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-31 09:02:22 UTC
*** Bug 257519 has been marked as a duplicate of this bug. ***
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-31 09:02:52 UTC
Workaround in bug 257519 comment 0
Comment 5 Daniel Shafer 2021-07-31 09:20:01 UTC
So I can literally say I had spent over 100 hours (not consecutively obviously) trying to update this port.  It has been a real pain.  

I submitted the bug https://github.com/Guake/guake/issues/1621 which was the major issue on why the port was not updated.

Honestly, I gave up.  The lead dev admitted he doesn't have time for Guake anymore so it's all but abandoned, at least on halt for now.  The last release was February of 2020.

After speaking with koobs on IRC, we agreed to try and work on it this weekend to try and find a solution.
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-31 09:30:11 UTC
(In reply to Xevi from comment #0)

The mentioned links points to an entire file. Can you clarify what exactly it was seen/observed regarding "On the last guake release on github it's fixed " that made you believe this specific issue was resolved upstream, and in a release?
Comment 8 Daniel Shafer 2021-07-31 09:47:40 UTC
(In reply to edsonwolf@vivaldi.net from comment #7)

This is a solution to a problem, but the bigger problem lies in why the port is not updated as described in my bug report to the project.
Comment 9 edsonwolf@vivaldi.net 2021-07-31 09:51:06 UTC
I understood
Comment 10 Daniel Shafer 2021-07-31 09:52:21 UTC
(In reply to edsonwolf@vivaldi.net from comment #9)

Sorry it's late and I'm not trying to sound rude.  The frustration this gave me when it happened was pretty bad.  Let me work with koobs this weekend and I'll see if I can find a solution
Comment 11 edsonwolf@vivaldi.net 2021-07-31 10:08:09 UTC
Don't be rude, you're upset, I understand you.
Comment 12 Xevi 2021-07-31 11:04:16 UTC
(In reply to Kubilay Kocak from comment #1)

I said that its related with the python version due the initial error of the stack trace is "platform module has no attribute linux_distribution".
The last python version that has suport for "linux_distrubution" was 3.7 https://docs.python.org/3.7/library/platform.html#platform.linux_distribution

If you check the last version of the utils file it don't have any references to "linux_distribution" https://github.com/Guake/guake/blob/master/guake/utils.py
Comment 13 Daniel Shafer 2021-08-01 09:42:40 UTC
This is most likely not the finished product, but I have started a review for the updated port.

I only have Python 3.7 on my system, and it's too late for me to go through the whole process of building 3.8 which would require rebuilding a ton of packages on my build server which is an 8th Gen I7 Intel NUC.

This runs fine for me on Python 3.7: https://reviews.freebsd.org/D31371

I will attach the diff as well.  If you wish to confirm the issue you guys mentioned still exists, let me know.  If not I'll try and test more tomorrow (Sunday evening).
Comment 14 Daniel Shafer 2021-08-01 09:44:44 UTC
Created attachment 226827 [details]
x11/guake patch