Bug 255733 - audio/libogg: Switch to CMake to enable config-file packages
Summary: audio/libogg: Switch to CMake to enable config-file packages
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Christian Weisgerber
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-09 21:17 UTC by Daniel Engberg
Modified: 2021-05-14 14:28 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (naddy)


Attachments
Patch for libogg (3.71 KB, patch)
2021-05-09 21:17 UTC, Daniel Engberg
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Engberg 2021-05-09 21:17:13 UTC
Created attachment 224797 [details]
Patch for libogg

Backport CMake fixes from upstream and switch to CMake
PORTVERSION --> DISTVERSION as per Porter's Handbook
Replace downloads.xiph.org with ftp.osuosl.org (redirects) in MASTER_SITES
Don't build static lib (couldn't find any users in ports tree)

Compile tested on 13.0-STABLE #0 stable/13-n245283-70a2e9a3d44 (arm64) (make, make check-plist, make test)
Poudriere testport OK 12.2-RELEASE (amd64)
Comment 1 Daniel Engberg 2021-05-10 12:44:53 UTC
Reported issue to upstream about Makefiles in docs dir
https://github.com/xiph/ogg/issues/76
Comment 2 Christian Weisgerber freebsd_committer 2021-05-10 20:16:42 UTC
Thank you, but I disagree with all of the proposed changes.

There is no reason to switch to cmake, which is a heavy dependency. The included autotools build framework works out of the box.

PORTVERSION is the more common idiom in the ports tree. Both variants are fine, portlint agrees.

downloads.xiph.org is the canonical URL.

We generally install static libraries to permit static linking.
Comment 3 Daniel Engberg 2021-05-10 20:44:10 UTC
As I wrote it provides CMake package files which is beneficial as we see more and more projects overall moving away from autotools and many users already depends/pulls in CMake so I don't really see that as an valid argument.

While both are still valid DISTVERSION is preferred (since a few years back) so might as well switch since we're doing changes but if you strongly want PORTVERSION I don't mind keeping it.

Direct links are in general preferred over redirects (same goes for http --> https redirects).

As for static libraries we're slowly moving away, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=255735#c5 as that was recently discussed.
Comment 4 Christian Weisgerber freebsd_committer 2021-05-14 14:28:04 UTC
libogg (and libvorbis) are old and stable projects. Existing software deals with the way they are now. There appears to be no need to install additional cmake files; not even Debian does.

You have strong opinions how the ports tree should be reshaped. Get portsmgr to issue corresponding guidance, and I'll follow suit. As is, I reject such changes.