Bug 255736 - KDE Plasma stuck on black screen with virtualbox-ose-addtions modules loaded
Summary: KDE Plasma stuck on black screen with virtualbox-ose-addtions modules loaded
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-09 21:25 UTC by kam
Modified: 2021-09-17 16:04 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kam 2021-05-09 21:25:00 UTC
I'm running FreeBSD 13.0-RELEASE in VirtualBox with virtualbox-ose-additions-6.1.18_1 and virtualbox-ose-kmod6.1.18_1 and whenever I start Plasma, ether through sddm or xinit, it stays stuck on the loading screen. When I disable vboxguest and vboxservice then Plasma is able to start.
Comment 1 Graham Perrin 2021-05-11 17:31:32 UTC
If you have not already done so: 

1. stop the guest
2. set the guest to use VBoxSVGA
Comment 2 Jason W. Bacon freebsd_committer 2021-05-15 16:25:30 UTC
See if it works with guest additions for a user who is not a member of wheel.
If so, then it's probably the same issue described here:

https://github.com/outpaddling/desktop-installer/issues/8
Comment 3 kam 2021-05-17 12:27:05 UTC
(In reply to Graham Perrin from comment #1)
this was the issue, switching graphics controllers worked perfectly
Comment 4 Graham Perrin 2021-05-17 21:56:58 UTC
(In reply to kam from comment #3)

Thank you for confirming. 

Related: bug 254266 comment 7 – I'm to edit the package message, maybe later this week. For fewer users of emulators/virtualbox-ose-additions to have the pitfalls of VMSVGA …
Comment 5 Gleb Popov freebsd_committer 2021-09-17 16:04:28 UTC
Closing this as "Not a bug", meaning that this is not "our" (kde@) bug. Since the problem with VMSVGA vs VBoxSVGA is well known, there is no point to keep this bug open.